cannot rename tracks

Cubase 10.5 Pro, Windows 10.

When I doubleclick on the trackname, I cannot rename it (as I could in earlier versions.) Same with Midi and Audio tracks.

Does anybody else experience this as well? Any solutions?

Thanks, Stefan


Please make sure you don’t double click to the right-corner where the Track Versions arrow (controller) is. Click to the middle or on the left side, please.

Thanks Martin.

I tried clicking everywhere… left, right, totally left… it doesnt work. Anybody any more ideas?


Could you try in Cubase Safe Start Mode, please?

… having the same problem, whereever you double click, no effect. Starting Cubase in safe mode doesnt help as well. Any news on this problem ?
Have opened a new thread in the german forum. Some people report the same problem, at others Cubase 10.5 runs normal. No solution there so far…


Could you rename the track from the Inspector or from the MixConsole, please?

yes, this is poss,…now we are at the same state as in the german forum


What graphic card do you have, please? Could you make a screen video, maybe we will see something…

I have Geforce GTX1080. In the video you see that I cannot edit the track name in the track list of the project window, and also not in the inspector. But I can edit it in the channel setting window and also in the mixer(the latter not showed).


Try to update your graphic card driver, please.

If it doesn’t help, try to use native Windows graphic card driver instead of the manufacturer driver.

newest driver now installed, thanx for the tip, screen has become a bit sharper. But Renaming problem not solved
Not clear how “to use native Windows graphic card driver instead of the manufacturer driver.”


I would try to reinstall the driver and keep Windows to use the native driver.

…i get stomache ache doing this. I had extra bought the expensive GTX1080(at that time) to run my ressources eating flight simulator software with high fps and no artefacts. If I deactivate the Nvidia software now these benefits will be history…

I just started having this same issue out of nowhere. Win10. I’ve been working all day and all has been well until suddenly I can’t double click or rename anything in the tracking window tracks. Works fine on inspector doesn’t seem to respond on mixer window either… wth?