Cannot type } in text frames

Hello,

this is maybe a bit similar to this thread https://www.steinberg.net/forums/viewtopic.php?t=155640

When I want to add something like {@ … @} in a text frame, Dorico won’t let me enter the last curly brace, “}”.
I can type it anywhere else, so it seems it is not blocked all over the program, only in the text frames.

How come?

Swedish localization and keyboard, default language in Dorico. No macro scripts active.

Thanks
LAE

I have the same, also with a Swedish keyboard layout.
Same thing when trying to add a prefix/suffix for Rehearsal marks
in Engraving options.

Jesper

How is that character typed on the Swedish keyboard? Where is the symbol located? What modifiers does it require?

AltGr+0.

Shift+0 is a =

And that is the zero in the number row.

On a Mac I type alt/shift 9 for }
and alt/shift 8 for {
alt 8 for [ and alt 9 for ]

Jesper

I suspect that’s the problem; Dorico treats AltGr as Ctrl+Alt, rather than as a distinct key. Does typing Ctrl+Alt+0 produce the expected bracket in other applications?

Yes it does. Ctr-alt-0 and altgr-0 is the same, we use either one.

I just realized that this might also be the reason to why ctrl+alt+2 never works for switching to galley view; ctrl+alt+2 is an “@” on a swedish keyboard…

Could I avoid all these problems by setting windows to english language and keyboard? Which setting is the best, EN UK or something else? And what keyboard layout for the physical keyboard? And is this actually something you recommend, or are there other better ways?

Sorry, it works now for me in text frames, just not as prefix/suffix for rehearsal marks.

Jesper

Have you modified the shortcuts in prefderences?

It Works ok here; for eksample:
{@projectname@}
Written successively on a noirwegian laptop-keyboard as:
AltGr + 7,2 - projectname - AltGr +2,0

I have. If I reset all shortcuts in preferences, it works normally. So the next question is — which one of all my custom keycommands caused this not to work?