Can't activate: eLicenser too old

Not sure why I don’t see a zillion other posts saying the same thing; I’m upgrading Cubase just like I have forever (and ever), but eLC is giving me the finger.

With the latest eLC version installed (6.12.5.1278) I installed Cubase 11 upgrade (MacOS Mojave) and went to activate in eLC, and:

  1. the Enter Activation Code dialog won’t paste the full activation code, as I’ve always done. Hmmm…

  2. manually typing in the code, eLC has 8 boxes of 4 characters; Cubase 11 activation is 5 boxes of 5 digits. weird. That said, eLC did enable the Activate License when all 25 chars of the C11 activation code were in there, never mind that the last box and half of the penultimate box are empty.

  3. clicking Activate in eLC fails, with a dialog box that says, “The currently installed version of the eLicenser Control (eLC) software is too old.”

wtf?

– jdm

Same issue. I received the message from the Steinberg President admitting to the licensing problems, but I’m wondering what the timeline is for resolving these and what I should do to check if there has been a resolution.

OK, never mind, I found the answer: you HAVE to use the Activation Code and push it through Steinberg Download Assistant, using the “Enter your Download Access Code” button in the upper left. When you do that, SDA brings up eLC with a completely different Activation Code, and thus eLC is happy.

  1. Unless I’m totally cracking up (a non-zero probability…), this is a new procedure, different from any other Steinberg activations I’ve done over the years. And that’s fine, but I did not see anything that would alert me to this change in the README etc. That said, I probably didn’t read it very carefully, as I’ve done a zillion Steinberg eLC activations before. -> Maybe the README could be (a lot) more vocal about it?

  2. The message I got in eLC when I tried to input (what I thought was) the Activation Code was very unhelpful, and literally pointed me in the wrong direction. The error message says that the eLC software is too old, so download the latest and install. I already had the latest installed. -> What it should have said was something indicating that the Activation Code I had was really a “Download Code” to be applied in SDA, which would then interface with eLC to do the actual activation.

3, In SDA, the big button in the upper-left corner says, “Enter your Download Access Code”, not anything about and Activation code, so naturally I did not think it applied, as I had already downloaded and installed the software. -> Steinberg, please make it much more obvious that the code you give out at purchase is NOT an Activation code, but rather a Download code, and that the Download code must be redeemed through SDA, not eLC directly.

Hopefully this note will save the next person from having to be frustrated and delayed. Maybe Steinberg will even make changes similar to what I suggest, above, and save people the initial frustration of having it not work, too. That would have saved me valuable time…

Party on, Garth.

– jdm

2 Likes

I think the idea is that you MUST have your cubase on public network at some point. So they should remove the suffix pro.

Hi! I have the same problem. I bought the Cubase 11 upgrade from 10.50 and The eLicenser Control Center (Version 6.12.5.1278) has 8 boxes of 4 characters each, and my activation code received by email has 5 boxes of 5 characters each. Anyway, I copy-pasted the activation code and appears a dialog box that says, “The currently installed version of the eLicenser Control (eLC) software is too old.”

It worked. Thanks.

1 Like

MEIN GOTT IM HIMMEL (I’ve been waiting years to write that. :smiley: )

  1. Thanks for the solution.

  2. This may take the cake for unforced error by Steinberg… and that’s saying something.

What kills me is that I downloaded the program and gave it a test drive and I actually upgraded because… for the first time in a decade… my settings from the previous version transferred over. And I thought. “Wow, they finally get how to do upgrades!” Spoke too soon. :smiley:

thanks this worked for me