Can't add bar rest

I’ve been trying to add a whole bar rest to the top voice on the treble clef staff. I don’t know how the whole bar rest got there in m. 1. For mm. 2-4, it seems the best I can do is show 3 quarter rests, which I definitely don’t want:
Image 2-19-19 at 9.03 AM.jpg
Note that “Show bar rests in empty bars” is in fact enabled.
Image 2-19-19 at 9.03 AM.jpg
Mm. 1-4 in the top staff should in fact be “empty,” because I input the chords in the bottom staff and used cross-staff notation to move them up.
Any ideas? Many thanks in advance for any suggestions.

Hi aef110.
Please search the forum : https://www.steinberg.net/forums/viewtopic.php?f=246&t=155205 is like five threads below yours!
To make it short : you cannot add a bar rest into a voice that is empty. So go on with your engraving, and once there’s something in your upstem voice 1, go back to the first bars and add your bar rests. It should then work as expected.

Also, for cases like this, you may want to turn on voice colors. If you want consistent bar rests, you need to use voices consistently. If the cross-staff chords belong to the RH, they should be in Upstem Voice 2. If they’re in LH, Upstem Voice 1.

Do pay attention to this Notation Option. If you set it correctly, this whole problem will probably disappear.

Marc, thanks for your suggestions. I did search the forum and found related issues but not this exact one.
Strangely, the top voice is not empty, as you can see in the first screenshot in my post. I have no idea how that whole rest in m. 1 got there and I can’t seem to reproduce it, though I was able to delete it.
I also turned on voice colors, and without changing anything, all the voices are in fact consistent, so voicing doesn’t seem to be the issue:
Image 2-19-19 at 1.27 PM.jpg
Adding the soprano voice again results in 3 quarter rests rather than a whole rest:
Image 2-19-19 at 1.29 PM.jpg
It seems I’m back to square one. I’ll try the remaining suggestions.

Sorry, aef110, I did not look at your picture closely enough. Pianoleo must be right, as usual, so make sure you enable bar rests if you want them to show. Have you tried selecting the first bar rest, and press r to duplicate on the next staves?

That did the trick. Thanks! (As a still-new user, finding all the options panels is confusing, to say the least. To me as a new user, it’s rather counterintuitive that there are bar rest options in layout options, engraving options and notation options, or that there even are different options panels. It wasn’t even clear which options panel I was seeing since I was just looking for rest options. I guess that’s the price of power.)

Engraving Options are global.
Layout Options are layout-specific.
Notation Options are flow-specific.

There are good reasons for each option being where it is, though that does often mean that options for any specific “thing” (rests, for example) may be spread across multiple dialogs.

Thanks for the keyboard shortcut. It’s probably obvious that I’m still a new user, so I’m just learning how Dorico works. It’s pretty different from other notation programs, though I’ve been amazed at what I’ve been able to produce with it thus far even before learning much of how it works.

By the way, does anyone know why my images are displaying only as links? Images by others in this forum display correctly directly inside the post. Do I have to host the images somewhere else and link to them? Right now it seems I’m uploading attachments and posting the links inline.

I use Greenshot to host screenshots elsewhere, and then I paste the link into forum posts using [ img ] tags.
There’s a method that involves uploading your image directly to the forum, then previewing your post, clicking the image link and then pasting it between square brackets in your actual post. The best part of a year ago this functionality broke for my user account; I don’t have any idea why! See https://www.steinberg.net/forums/viewtopic.php?f=132&t=138980

Thanks. I’m sure Dorico’s designers thought everything through from the ground up and came up with good solutions. Probably this is just years of working with other notation software (in my case Finale, Sibelius, MuseScore) and I just have to get my head around the new concepts like “flows.”

Lol, you, Dan and Pianoleo need to be on the payroll!
high five

Most of us have been there. Hang in there, once the penny drops and you see the light, there is simply no going back!

Thanks! I think I’m quickly reaching that point. The different modes do seem to add complexity, though I’m already getting used to them. (I don’t understand why only the first of a series of chained ties can be flipped in write mode but engrave mode doesn’t have this constraint, for instance. Maybe there are still some wrinkles to be ironed out?)

Anyway, I trust the incredibly talented development team and I’m sure there’s a good reason behind all their design and UI decisions. I’m also pretty amazed at how much I’ve been able to do with Dorico as a new user, even before learning much of the new way of working.

I’m fighting with this whole bar’s rest business in just a simple, two part texture.

3/8, two voices: upper voice = three quavers, lower voice tacet.

I have “bar rests in additioal voices” activated in Notation Options and “show bar rest” activated in Engraving Options.

A rest doesn’t appear automatically and I can’t find a way to insert one manually. What am I missing?

Edit: Just discovered shift/B “rest” which worked.

Sorry …

Are you at the end of the flow, or do you have more notes in the second voice coming up? If so, have you entered them yet? If not, go ahead and enter them - the rest may then appear automatically.

If not, you’ll need to force it. Set the caret at the start of the bar, hit V however many times to get the caret to the correct voice, then type Shift-B rest Enter.

Thanks Pianoleo - discovered it as you were typing - see edit above.

Not at end of flow - first bar.

But do read the other bit of my post, because it may help you further along: if you have a bar where one voice is resting, don’t bother entering a rest manually - Dorico will do it for you when you later enter notes in that voice.

Yes - did so - had been through voice “cycling” and also entered notes in subsequent bars - no automatic rest appeared although one showed itself in a further instance of exactly the same note/voice combination.

The rests in the lower voice won’t show automatically until after the first note has appeared in that voice. If you set the Notation Option correctly, bar rests after the first note in that voice should appear automatically, as shown here: