Can't change grid line in key editor anymore

I accidentally made some change in key editor, and now the quantize option become gray, and I can’t change the number of grid line anymore.
The screenshot is in the attachment, please help.
Thanks.

You have changed your grid from Bars+Beats to time, change it back to bars+beats and you should be good to go.

don’t you read the part where he says it’s gray and he can’t change it? gees…
Same thing happens to me… for days, and I can’t correct it.

I’ve just had the same problem after resetting preferences. KHS’s solution worked.