Can't change key signature in score

I’ve got a project that I’m changing the key of the entire piece from D Major to B Major. I successfully transposed all the midi data and the chord track.

But in the Score Editor when I try to edit the Key Signature nothing happens, the signature always remains in D. Turns out I can’t change the signature to anything else. I’ve tried using the Keys tab in Symbols. I’ve right clicked on the current signature and selected another key, and also double-clicking on it and using the Edit Key dialog. I’ve done this with Page Mode both on and off. In every case everything behaves normally except the key signature stays the same.

I’m wondering if I’ve inadvertently locked it somehow.

How are you trying to change the key signature? (and, just as important, how did you create the original key signature?) If you created the original key signature via the main Staff Settings dialog, then you can change it by editing it there, or by double-clicking the key sig on the staff itself, or by adding a key signature from the Symbols palette… but if you had originally created your key signature by entering it from the Symbols palette, you can’t change it via the Staff Settings dialog, only by double-clicking on the key sig and editing it in the little window that appears.
Another possibility that might confuse, is if you had changed the option “Key changes for the entire Project”. (A quick test would be to try and do some key signature manipulations on a different track/staff).
You are certain that you haven’t done any Hidden key signature events?
Maybe Steve can think of something else that might be getting in the way.
If you are still stuck, maybe you could upload the project (you can delete all the actual notes first… just leave us the tracks empty apart from their score settings :wink: )

I originally created it by adding a signature from the Symbols Pallet. I tried all the methods you mentioned and none worked. I do normally have “Key changes for the entire Project” turned on. When I turned it off, I was able to change each staff individually to B Major. But then I turned it back on and they all stayed on B Major - until I tried to use the Pallet to set another key (just to see what happened) and they all reverted back to the original D Major (which isn’t what I selected from the pallet). Which is weird. So I turned it back off and changed them on a staff by staff basis. Still unclear what’s happening, but at least the signature is what I want.

I checked this out. and saw an anomaly- I used the palette to enter some key sigs, but aside from the one in bar one, they were not appearing, which sounds like what you were seeing, raino. I switched to Edit view and I was able to add them. Then I looked in the list editor and there were several key sigs with the same start times. I deleted them.

After that everything worked normally. So maybe there’s something buggy going on.

So, I guess, what do you see in the list editor? (next time you come across this weirdness)

Hi Steve,
did you test this on PC or Mac? I’ve just tried here (on Mac), and everything seems perfectly normal (“Key changes for entire Project” enabled… initial key signature applied by adding it from the Symbols palette, and adding other key changes later in the project). They are all correct, and editable, here.

PC

Do you have the time to do a quick test on Mac?

I’ll do so when I get back from the out of town gig tomorrow. Also, I’ll find the exact recipe here.

You mean, you actually play music? :open_mouth: :laughing:
Have a good gig :slight_smile:.

Yes! When I remember my bow :wink: http://www.steinberg.net/forums/viewtopic.php?f=198&t=80441#p457333

So when the audience says “take a bow”, they aren’t necessarily applauding? :stuck_out_tongue:

No, they’re offering a hand. :wink:

Well I felt dumb at not thinking to look in the List Editor. :blush:

This particular project only has one key throughout, so nothing should be changing later on. When I opened it in the List Editor each track had 2 key sigs and all of them were at the very start. So this seems like what Steve saw. However when I deleted all of these sigs while watching in the Score Editor some of the tracks changed from B Major to C (like I’d expect), but three tracks changed to D instead. So in the List Editor there are zero key sigs, but in the score I can see three staves showing D Major??? What distinguishes these three is that their MIDI Parts don’t start at bar 1 like the tracks that changed correctly. They start at different bars later on.

So I reverted to the initial version of the project, Then I dragged the starts of the late appearing MIDI Parts so that they too begin at bar 1. So now every track has a MIDI part starting at bar 1. Go back into the List Editor and delete all the key sigs. Same thing happens as before - the same three staves show D and all the rest are C. Meanwhile the List Editor says these key sigs don’t exist.

And if I go into Settings and enable “Key changes for entire Project” then attempting to add any sig from the Pallet results in all staves changing to D even though I didn’t select D from the Pallet. It’s like the Project has a D Major infection.

Personally, I have always avoided editing anything “Layout-based” or “staff-based” in the Score Editor unless I am working on a single MIDI Part that runs the whole length. (when you have multiple Parts on a track, if there are “gaps” between them, you could end up with staff events that actually belong “in the hole”… just asking for problems later :wink: )

When “Key changes for the entire Project” is active, any key signature events that you write are not written to the staff (and therefore not to the corresponding MIDI track). So, any key signatures that you see in the List Editor must have been written while “Key changes for entire Project” was not active. When you switch that option to “on”, any key sig events that belong to a staff are ignored. (Golden rule… decide whether you want that option on or off, then stick with it… they are mutually exclusive :wink: ).
Or, think of it this way…
There are two parallel key signature paths, totally independent of one another, and only one of them can be active at one time.
So… does it still go funky if you do the following?..

  1. Go into the List Editor and delete all Key Signature events
    1b) (in case there is already a key signature set for entire project)… activate “Key signatures for entire project”, and delete any key sig events you see in the score.
  2. Decide whether you want "Key signatures for entire project or not, and set that option accordingly.
  3. Now set your key signature(s)

I’m with you on deciding whether to enable “Key changes for entire Project” or not and sticking to it. Up until this issue came up I’ve always gone with it enabled. I only disabled it to try and figure out what was happening. Following your directions above, after deleting all the sigs using the List Editor I was left in the state described at the end of my previous post - a mix of staves showing either no sig or D Major. Then I enabled “Key changes for entire Project” and nothing changed, same mix of sigs remained. So I selected one of the D sigs and hit delete. Instead of getting rid of the sig, that changed the sig on all the staves to D. Then I selected the same sig again and hit delete - that deleted all the sigs. And now I can set it to B and all behaves normally.

Before starting to change the key I had saved a safety version of the project in D under a different name. The project had always had “Key changes for entire Project” enabled for its entire existence. Checking the List Editor there were no key sigs in it, as expected. Then I opened the score and used the pallet to change sig from D to B. Nothing happened, all staves still showed D. Then I thought maybe it was just a display thing so I hit UPD, and still all the sigs were D. I then selected a sig and hit delete nothing changed, still D. Select and delete a second time cleared all the sigs. Then I typed ctrl-Z and the sigs went back to D as expected. But a second ctrl-Z changed all the sigs to B. So at some level Cubase knew about my original attempt to change the key but didn’t fully execute the change.

The bottom line seems to be that repeatedly deleting the sigs until they went away cleared up the problem.