Can't change latency/buffer without restarting Cubase?

Hi,

As the title says, how can I change latency/buffer setting mid-session, or even between projects without restarting Cubase? I can change the buffer size on my usb sound card, but nothing changes in Cubase. Is there a quick fix to this or am I doing something incorrectly?

I am using Cubase 7.5.2 with an RME Babyface on a Win 7 64bit system running an i7 2700k.

Thanks for your help!

Does the RME not have a control panel within Cubase?

Devices>Device Setup…>VST Audio System-RME whatever…

Most interfaces have a ‘Control Panel’ there where you can change the buffer size.

Sometimes I have to change my settings in the MOTU audio panel, go back to Cubase and switch to the Generic ASIO Driver (I guess another driver would work if you have one), and then switch back to my default MOTU driver before the latency is updated.

Aloha and +1
Jimmys69 is right on.

Devices>Device Setup…>VST Audio System-Steinberg/Yamaha n12 here.

I often changes settings on the fly.
I track with buffers lo and playback with buffers hi.
Depending on the project and the client, sometimes every few minutes.

Never have to restart the Cubase programme.

I can change the buffer size on my usb sound card, but nothing changes in Cubase.

As mentioned try changing buffer setting not at the sound card
(tho’ that should work) but directly in Cubase.

Good Luck!
{’-’}

Thanks Guys - been using that menu option for years. It works intermittently with my current setup, so after a few tries, it’ll switch over.

With the Steinberg MR 816x I can change the buffer setting and after a short pause it changes over immediately. As you would hope/expect I suppose.

Thinking of buying the UAD Apollo - does anyone know whether that switches setting without a restart?

Unless the driver has a bug, it is never necessary to restart cubase. Just always do it from within Cubase.

I think it is a bug from RME, I’ve been using the babyface with W8 and sometimes it happens to me as well

it’s always worked flawlessly for me with a rme/hdsp card/driver.

(However, I’d never been able to switch the buffersize back when using an m-audio card w/o restarting cubase…)