Can't change sample rate in Dorico 3.1

Sample rate issue with Dorico 3.1 and Focusrite Scarlett 6i6 (1st gen.) on PC running Windows 10 (version 1909).

I have set the default sample rate in Windows 10 to be 48 Khz and this is matched by the settings I’ve chosen in the Scarlett MixControl software. This sample rate setting works flawlessly for every application handling sound (Google Chrome/YouTube, Spotify, VLC media player, Amazing Slow Downer, Transcribe!, BIAS FX standalone, Winamp, Steam, Guitar Pro 7.5, MuseScore 3, Sibelius Ultimate 2020.1 and Cubase 10) EXCEPT for Dorico.

No matter if Dorico is the only software I’m running or if it’s simultaneous with another application, it changes the sample rate from 48 to 44.1 kHz on startup. If I have the Scarlett MixControl software open when starting Dorico, I can see it switch over from 48 to 44.1 kHz when Dorico is going through its launch process (checking audio interface, plugins, etc.). It doesn’t switch back to 48 kHz when closing either, it just leaves it at 44.1 kHz and I have to manually adjust to 48 kHz. Unfortunately, Scarlett MixControl won’t let me adjust the sample rate as long as Dorico is running, which would otherwise have been a quick solution to the problem.

At first I thought Edit -> Device setup… within Dorico was the way to go, but “Device setup” is greyed out and I can’t even click/select it. I have also tried changing the settings from within Dorio through the Edit -> Preferences -> Play -> Audio Device settings, but the Audio Device Setup button there is also greyed out, and “Suspend audio device in background” does not change the sample rate behavior, no matter if the box is ticked or not.

Perhaps I should mention that Dorico itself doesn’t have a problem playing back audio when it runs at 44.1 kHz, but it does make every other application I wish to run simultaneously (for when I’m listening to an audio file while transcribing, for example) screw up the audio playback, and I really do want my entire system to run at 48 instead of 44.1 kHz.

If it matters at all, it’s a custom built PC with these specs:
MoBo: ASUS Prime Z370-A
RAM: HyperX 32GB (2x16GB) DDR4 3000Mhz CL15 Predator
PSU: Fractal Design Integra M 550W
GPU: ASUS GeForce RTX 2060 Super ROG Strix Gaming OC EVO
CPU: Intel Core i7 8700K 3.7 GHz 12MB
CPU air cooler: Be Quiet Pure Rock
SSD boot drive: Samsung 860 EVO 500GB M.2
HDD storage drive: 3TB Seagate Ironwolf 64MB, 6G/s, 5900RPM

I have watched the “Troubleshooting Playback Issues in Dorico” video, searched the forums and asked the same question at the Facebook group “DORICO - The Next-Generation Scoring Software” but received no replies as of yet.

Any suggestions…?

I wonder why ‘Device Setup’ is greyed out with you, I’ve never heard of such a case before.

Anyway, try this: Stop Dorico and go to C:\Users<yourname>\AppData\Roaming\Steinberg\Dorico 3
There is a file called preferences.xml, you can open that in a text editor like e.g. Notepad.
In line 14 is the value for the default sample rate, change that to “48000.000000”.
When you then restart Dorico, does it pick up the new sample rate?

On both of my macs, Device Setup always grays out when no project is being opened by Dorico.

That’s correct: in Dorico 3.1 the Edit > Device Setup dialog, or the corresponding button on the Play page of Preferences, is only enabled if a project is open.

I would advise against activating the ‘Suspend audio device in background’ option, as this can cause problems with some audio devices.

Changing the sample rate value in the XML file did indeed fix the problem. Now Dorico plays nice with all the other audio applications, just like I hoped it would. Thank you very much, Ulf!