Can't change the Key Signature when the Display Transpose is ON

This is not a very serious issue, but maybe it could be fixed…

STEPS:

1… Go to Score Settings (Scores / Settings…) and uncheck:
“Key Changes for the Entire Project”

Screenshot 1

2… Make sure that the Display Transpose button is OFF (make sure it doesn’t look like the one below).
image

3… Add a Key Signature to a +2 semitones stave (let’s say we add “B maj” to a trumpet stave).
4… Turn on the Display Transpose toggle button (the 5 sharps signature will switch to a 7 sharp signature).
5… Try to change the signature of the same stave to “C# maj” (theoretically, the key signature should switch to a 3 flat signature, but it doesn’t).


RESULT: the Key signature doesn’t change.

Yes, what’s happening is that the Display Transpose for the instrument is reset when you change the first key signature of its staff in the score. You can check it live in Score Settings. (probably a small bug or by design, I don’t know). So you’ll simply have to set again the transposed display.

1 Like

I wouldn’t use “instrument” because in Cubase there are two types of instruments: virtual/VST (NI Kontakt, Steinberg Halion, etc) and external (the ones that don’t fall in the VSTi category: e.g. a modular synth, a digital piano, etc).
I know that the context makes the reader understand exactly what you are referring to, but sometimes is better to use the right terminology.
I think “Stave/staff” would’ve been a better term. Trumpet, Piano, Timpani, etc, are timbres/programs/plug-ins/sounds. I may be mistaken though…

I’m not sure I understand what you mean by “checking it live”. Check what?

Well, the term instrument means … instrument.
If I wanted to name VST Instruments I would have written : “VSTi” or “VST Instrument”
We are talking about music, score and precisely Score Settings, and the Display Transpose option for (musical) “instruments”: Trumpet in this example.
As you rightly addressed your concern in your own reply, this was indeed the right terminology in the context it was used. :slight_smile:

As for the “live” question, just look at the Display Transpose value for the instrument in Score Settings while you change the key signature on its staff.

(here is a video)

Display_Transpose_key_signature_change

1 Like

As it’s the case with positive numbers (which are written as they are, without a “+” sign), by “instrument” alone a Cubase user should understand that the discussion is about a VST/external instrument, not about something that helps you acomplish something (a tool). If you ask me “What instrument are you using?”, my first thought should be “Kontakt/Halion/Spector/etc”, not “Violin/Piano/Trumpet/etc”. It’s just my opinion. This is why I said that I wouldn’t use the term with the meaning of “musical instrument”.

No. I didn’t say that “instrument” (as “musical instrument”) is the right terminology. The term “Instrument” should be used only when you are referring to a MIDI controlled “VST/external” component of your studio. What I was trying to say is that I understand that in the given context “Instrument” as “Musical Instrument” might also be correct (not “is”; “might” be correct!). Maybe I’m making too much of a big deal out if this…

Thank you for the video!
Apparently, this is a winOS issue only. On my MAC (macOS Mojave 10.14.6, Cubase 10.5 and 11) the Display Transpose for the trumpet staff doesn’t reset.

GIF

(Display Transpose button active)
dt

Question:
I forgot to indicate the name of the instrument on the second staff. What is it?
According to you, a Cubase user would answer: HALion? or LoopMash?

image

So yes, again, it all depends on context.

Totally agree :slight_smile:

To get back to the topic, on Windows you are actually able to see where the problem lies, and fix it. Because you just have to apply again the Display Transpose to the staff in order to display the right key signature. That’s how I found it out. So if there is an issue, in my opinion it is rather on MacOS side because that (Semitones) displayed information is not updated.

1 Like

The second staff could be linked to a track connected to a HALion/LoopMash instrument, you know. :stuck_out_tongue:

The phrasing in the question you used as an example should be:

  • I forgot to name the second staff. What is it?

Also, you could’ve said:

  • I forgot to indicate the name of the program/patch/plug-in on the second staff. What is it?

Not true. The Display Transpose value in the Score Settings window will keep the grounds (will stay the same) no matter what I do outside it. I verified this on both Cubase 10.5 and 11 versions.

Here’s what’s actually happening on your winOS machine:
The option “Local Keys” is switched on. That’s why the Display Transpose of the Transpository Instrument staff resets. Uncheck it and it will behave the same as on my MAC.

The “Local Keys” option cannot be switched on or off (greyed out) because you deactivated “Key Changes for the Entire Project” in your 1st step. :wink:

But you are right about one thing: same behavior on Mac and PC (1 point for you! :slight_smile: )

Now that we are on the same page, the fix is, as I said, to apply again the correct Display Transpose for the transposing instrument: set the value, or switch to another instrument and switch back to the initial one.

Are we in agreement?

1 Like

Crab :grimacing:

Hurray! :partying_face:

Sometimes, the Score Editor misbehaves if the MIDI part of the layout is split in two. I think this was my problem. The fix would be to always keep the parts on my track glued.

Yes. Thank you!

1 Like