Can't change VST instrument assigned to midi track?

I bought a bunch of midi tracks and am trying to change the instruments that are assigned to each track.
It should be easy right? I open the multi program rack and navigate to the instrument I want … it loads okay, but as soon as I move to a different part of the song it reverts back to the original preset sound.
Can anyone tell me what I’m doing wrong??

Open the List Editor of the part and delete the first program change.

Thanks a million … I’m not sure why I can’t just change the instrument in the program rack but it worked like a charm.
Appreciate the reply.

Aloha,b

Also remember to scroll thru the entire MIDI track
looking for PChange messages.

They are usually at the beginning of the track but
sometimes you will also find then buried deep in the track.


HTH
{’-’}

:imp: :imp: sorry for bringing an old thread up but is there a way that you can change the settings so you won’t have to redo that every time?

This inconsistently but often happens to me too. I appreciate the tip to delete the changes in the list editor. I don’t ever recall actively putting the program changes in … I wonder what step I’m doing that is causing that line to appear in the editor?

I’ve found changing the MIDI channel seems to help the problem - sometimes!

Aloha a,
Several approaches here.

Once the MIDI file is loaded in Cubase you can:

1-Delete Controllers. …Menu/MIDI/Functions
2-Delete Continuous Controllers…Menu/MIDI/Functions
3-Delete Volume and Pan…Menu/MIDI/Logical Presets/Experimental
4-Delete Patch Changes…Menu/MIDI/Logical Presets/Standard Set 2
These steps are pretty powerful and complete so there is also a
5-‘Thin Out Data’ function…Menu/MIDI/Functions/‘Thin Out Data’.

Would be nice to have all (or some of) this done automatically
as the MIDI file is being imported.

{’-’}

In preferences, there are a whole bunch of options under “MIDI/MIDI File” that make Cubase selectively ignore various bits of control information when you import a MIDI clip.

In particular, I think the option “extract first patch” will cause program change/bank select messages to be imported or ignored. Try changing some of these options and see if you get anywhere.

I have what might be the same or a similar problem as the OP, but not having anything to do with importing MIDI - I create a 2nd or 3rd MIDI track, make a patch assignment to my Motif that is different from the first MIDI track, and then somehow when I get to play it, the patch assignment magically changes to the one the original track has.

Like I mentioned above, I can usually fix it by some combination of repeatedly reassigning the Motif patch, changing the MIDI channel, or throwing shoes at the screen.

Thanks for the above hints - I will look under preferences, maybe there is one that duplicates some features of the existing MIDI track onto the newly created one that causes that. I don’t know, it’s always been one of those things in Cubase that I have to take a deep breath and count to ten about.


Do you guys have any further thoughts?

Thanks -

Has ANYONE figured it out yet? I have tried all of the solutions above and EVERY TIME I hit stop all the instrument revert to the original. Why??

HELP!

FWIW, my problems probably went away completely when I made sure each track had it’s own MIDI assignment.

Thank you, Alexis!

I’m new to CUBASE… I have CUBASE 11, and a couple of days ago I ran into the same nasty problem: the only thing that worked for me was to pick “Instrument Tracks” under Edit, Preferences…, MIDI File, Import Options, Destination - Picking anything else under Destination will not work.