Can't create cue

In one flow of a 3-flow piece I can’t create cues. In the other 2 flows (and everywhere else I try it) cues are created as expected. It’s just this one flow. Obviously I’m missing a setting. It’s not the obvious Layout Options one; that’s set to show cues and I think it’s flow-independent. Can someone suggest what I’m missing?

Are you trying to cue a pitched instrument to an unpitched instrument?

Nope. Pitched to pitched. What I’m doing is putting in rhythmic cues to illustrate grace-note performance. It works everywhere except in this one flow, and all the settings seem to be the same. The name of the cue instrument is the same from flow to flow, and shows up on each cue. I’ve checked all the obvious things (e.g. am I in the correct measure–I am, etc.)

It might be necessary to share the project or flow, in that case.

Here’s a copy of the first 2 flows. Flow I is working. Flow II isn’t. (1.3 MB)

It works for me.

I find that if a popover doesn’t accept what I type (ie. it just closes without doing anything), making a selection from the list usually does work. In this case I selected the ‘q’ rather than just pressing return. I don’t know why this should be.

Yes, I remember that. In my setup, no list appears. On the other hand, when I choose another part for the cue, I do get a list, and selecting it works fine. I have had to hit return twice for the cue to take, but no list.

For an experiment I renamed the player with the cues from q to cue staff, because I have a couple of other instruments in there beginning with the letter c. This time I got a list of two of those other instruments, but not the cue staff.

Strange. And it’s still only in one flow.

New information: I created a new entry in the cue staff in the first movement (where everything was showing up as I expected) and tried to make a new cue. Suddenly, I had the same symptoms and couldn’t make a new cue.

I’m thinking that something is amiss with my copy of Dorico. Do I need to reinstall it, or is it still possible (as it often is with other programs) to just trash a preferences file?

Or, alternatively, should I just delete that cue part and start a new one?

I made a new cue part and everything worked as expected. Apparently something was wrong in the innards of the old cue part, who knows what. And I don’t understand why the version I sent worked for @Janus. Ah well, these things are sent to try us and perhaps we’re not meant to understand them…

Perhaps because I’m still on Dorico 3.5? (Any thoughts @Lillie_Harris ?)