can't create kontakt instrument

Since updating to 8.0.5 when clicking the create vst instrument track, either by the icon or via the menu, it doesn’t display the list where I can choose kontakt, it simply displays the instrument page so I have to select halion, for example. Also the create rack instrument icon and menu has dissappeared…

I’m seeing the same thing, perhaps it’s a preference setting?
I tried it before updating to 8.0.5 and when I hit the add button I got the dialog with the browse button and a VST instrument selector. Now I have to add external VSTis as a rack instrument and then get prompted to add a MIDI track. Project->Add Track->Instrument brings up the browser. I can still add Kontakt by using Add Rack Instrument.

Sorry if this sounds silly, but have you gone into the Plug-In manager and shown Cubase where all your Plug-Ins are installed? With the correct paths?

Interesting. I renamed the AppData Cubase 8_64 folder and forced a VST rescan. After that I was able to create an instrument track using a VSTi instead of the browser. However, as soon as you click the browser button the setting becomes sticky and always opens the browser. It has to be a setting in one of the xml files that gets changed automagically. After using the browser once it thinks you want to always use it for some reason.

I tried to find out what changes in the config but it looks like a lot of stuff changes every time you exit so I couldn’t track it down. Rolling back to 8.0 does not fix the issue either.

Does anyone know if there is a workaround for this?

LMAO, don’t send a boy to do a mans job.
I figured it out. The state of the browser window is maintained. I hit the Browse button at the top left of the browser and it collapsed to the normal dialog with the VST Instrument dropdown. DOH!
I spent a whole day trying to debug a feature. Nothing to see here, move along. hahaha

I am embarressed to say that I, too found I must have resized the window and it stayed in that position!!