Can't delete slashes

I promise I’m getting better… I started two threads today but then changed my mind, powered through, and figured it out. But now I’m stuck.

I started to try to add my first slashes. I added generic comping slashes, no problem, then decided to try rhythmic slashes.


The 1/16 note slash at the beginning of Bar 19 was added by accident so I tried to delete it. I can’t. First off, notice the grid. The note entry is set for 1/16 notes, which I selected while making rhythmic slashes in bar 18. But the grid is 1/8 notes and when I move the carat using the arrow, it skips over the 1/16 notes in bar 18. No matter what duration of note I chose, the grid stays on 1/8 notes.

I have tried searching Google and here for ‘How to delete a slash in Dorico’. I have used Shift-Alt-V to change the little note beside the carat to the slash symbol. I get multiple versions, with a 1,2 or 3 written beside it. But I cannot select any of the slashes and delete them. Whenever I click in the bar on top of a slash, the carat indicator changes from slash to note immediately.

I used the drop-down Write–>Create Slash Voice but again, as soon as I try to click on a slash, the cursor jumps to being a note again.

Strangely, even when the cursor shows the ‘note’ symbol, if I hover over a rest, I can see a greyed-out slash, but I move that over one note to an actual slash and it doesn’t light up in orange

Somehow I can’t get Dorico to understand that I want to be in slash mode and deal with the existing slashes. If I could light up one of the slashes in orange, I could maybe figure it out.

Any ideas?

Dear mset,
First of all, I 'd suggest you to learn how to quickly change the grid value. There are different workflows available, here’s mine. Create nice shortcuts if you don’t have an English or American keyboard layout (mine is French, I chose 1 and 2 keys for increase and decrease grid resolution). Default keybindings is set to [ and], watch how the picture in the bottom left corner changes accordingly.
Then, if you really want us to help you in a fast and accurate way, attach a minimal version of the project that exhibits the problem. With what you describe, I don’t understand why you cannot simply select the 16th note and delete it (this is all it should take!)
Hope this helps!

Hi there and thanks for the response. Yes, the trouble I’m having in selecting that 1/16 note is the big puzzle. I have been having a few other troubles and I am trying to figure out whether it has something to do with the keyboard I’m using (Corsair Vengeance K60).

I have tried everything to change the grid fore these particular bars but they seem to have become stuck on 1/8 notes.

Unfortunately it seems I cannot attach a Dorico project file here? I am trying to add it via the attachment tool but when I navigate to the project file and try to attach it, it says ‘Invalid file extension: Dorico’

Is this what you meant when you suggested I attach a minimal version of the project file? Is there another way to do this?

I suspect you might be trying to delete stuff within note input mode (with the caret active). With the caret active you can overwrite existing notes, but you can’t select and delete individual notes - the act of clicking adds new notes rather than selecting old ones.

To get out of note input mode, type Escape. Then select whatever you need to and hit Delete or Backspace.

Good gracious. Really?

Yep, that worked.

I guess I really have to understand that things that seem intuitive to me may be informed by my long use of Finale. So in note entry mode I can’t delete notes? I have to change modes for that?

Apparently.

But the weird thing is this - when I first read this post, I immediately went to my Dorico and clicked ESC and tried to highlight the notes in question. It didn’t work. Every time I clicked on the note, it would just make a ‘normal notation’ note appear in the bar.

I was just about to post that it’s not working, and decided to try hitting ESC one more time… and it worked.

This is a brand new gaming keyboard ( I have never played a computer game in my life other than Pong) which I bought because it was well reviewed and has the Cherry MX keys I like. I think I have some sort of issue with my keyboard.

Hit Escape. Then select the note on the page and delete it. Do not click the notes in the left panel - if you do that then Dorico thinks you want to insert another note!

Okay I got it. Yes I see now. The entire time, because I could not select the note I wanted to delete, I was assuming that I had to tell Dorico which value of note I was attempting to delete.

Onward we go, I will be aware going forward that I may have to get out of a particular mode in order to efficate another process. I guess with Finale, I am always telling it exactly what I want to do because I am forced to choose the function using the menu system. Here, I have to make sure I’m in the right mode.

Hey, this is interesting. Before I followed the instructions by Leo, I couldn’t change the grid values at all, but I was using the big buttons at the top left. So after reading your post I looked down in the bottom right and saw the little note icon. I clicked the arrow and saw the note value choices.

I clicked the 1/16 note and the grid changed right away! So thanks for that.

I will now try to understand why it is that the grid did not change while I was clicking the big note value buttons at the top left but changed right away when I clicked in that little box at the bottom left.

The grid and the note values are different things. Any note can be added with any grid value, but the grid gives you precision for clicking notes in at the correct rhythmic location, or for moving the caret with the arrow keys. It’s also useful for e.g. lengthening or shortening existing notes quickly. For example, if I want a minim/half tied to a dotted crotchet/quarter then the quick way is to set the grid to a semiquaver/eighth, add a semibreve/whole note, then go Shift+Alt+Left arrow.

Just as an aside, I now tried to get Dorico out of rhythmic notation mode and back into regular note entry mode. Nothing would work - Hitting ESC, choosing Write -->Note Entry, trying to get the carat to display a regular note by using Ctrl-Alt-V over and over.

Spent about 10 minutes on that. Then I clicked Write–>Note Entry and toggled it off, then toggled it back on again. It worked.

What I need to understand is - are these effects a function of my install or is this expected behaviour.

I have no idea why you’re using Ctrl+Alt+V. V - just V - scrolls through the existing voices on the stave.

This is unexpected user behaviour :wink:

Dear mset,
My next suggestion would be that you take the time to watch the beautiful videos on the YouTube channel made by Anthony Hughes. You might notice some changes, for Dorico has changed a bit since version 1, but the philosophy remains. And download Dan Kreider 's guide for the beginner (he also comes from Finale, it has proved to be really helpful to newcomers)
https://www.dropbox.com/s/6d2qmdapwqpxyn4/A%20Beginner’s%20Guide%20to%20Dorico.pdf?dl=0
You should be better informed about how deep and thoughtful this program is :wink:

Okay I see that clicking in the small box at the extreme bottom left changes the grid values consistently.

I’ve read every page of Dan’s guide, but with programs as complex as this, it’s impossible to explain all the situations that one might come up against. The main issue here is figuring out the difference in basic design philosophy. Dorico is way way better than Finale, it’s obvious. But there’s going to be a learning curve.

If I decide to make the change and buy the program, the first thing I am going to do is take some of the $$ I saved on the crossgrade from Finale and buy an hour’s worth of Dan’s time and get a one-on-one session. That will be way more efficient than trying to piece together how this thing works between Youtube, here and the manual.

I’ve checked out many of Anthony’s videos and they’re very helpful.

Perfect example. I just added a grand staff to my project. I tried to enter a piano chord, but Dorico will only let me enter one note. I can’t stack a C triad in the treble clef (right hand). I can enter a note and hover the mouse over another note and I see a grey notehead there but if I try to click that note into existence it doesn’t work. In order to do this I have to get in another mode. Intuitive to me? No, I would guess that if I’m in note entry mode I could enter as many notes stacked on top of one another to create a chord as I wanted. I’m sure there’s a good reason that Dorico won’t let me do this. But this is the challenge.

Just in case you missed it:
Shift+V to add a new regular voice
Shift+Alt+V to add a new slash voice
V to switch between existing voices

Either turn on chord mode (Q) or use the Shift+I intervals popover.

Try using a MIDI keyboard, you’ll see how easier it is to input stacked notes (or chords) :wink:

Well yes, obviously that’s the quickest way :wink:

Aha okay. I hadn’t found anything that laid it out like that before.

Yes thanks. As I figure out each thing I’m printing off the relevant instruction and making a book. I’m going to make this happen.