Can't drag notes in KE with 'Indicate Traspositions' enabled

As the title says, it’s damn straightforward to reproduce…
and it’s very very very ! annoying!!

PC, Win10, Cubase 9.0.20

Perhaps not so straightforward. Simply activating Indicate Transpositions did not stop me from dragging midi notes around…

Set the project root key different from the part’s root key so that the part is actually transposed with the ‘indicate transpositions’ options. Notes must be outta your control.

Confirmed here.

Can someone on Mac repro this too?

Here’s the repro:

  1. New project, new midi track, new part, add some notes in the key editor
  2. Set the project root key to C
  3. Set part’s root key to any other note
  4. In Key Editor, activate ‘indicate transpositions’

Result: Notes can not be moved using the mouse.

Confirmed!
Following the steps above, results in not being able to move midi notes with the mouse.

Evertone, are you on 9.0.20?

Yes, I’m on the latest CB 9.0.20.