Cant get a piece to midi to follow project tempo


I’m hoping someone might be able to answer this for me.

I have a piece of midi
MIDI piano …but at (6.29 KB)
a friend recorded for me, they recorded it at the wrong tempo (169, not 147).
When I import it into my 147 project it sets the tempo to 169, and if I attempt to set the tempo to 147 the midi doesn’t follow.
I’ve tried all the tricks I know, checking for any controller data and remove all midi data…but can’t get it to follow project tempo…

My understanding, which might be incorrect, is that midi is flexible in that it might be recorded at a tempo, but can always be modified to a tempo of choice, is this correct?


In the preferences tick “ignore Master track on merge” before you import the file, or if you already have the file loaded, set the MIDI tracks to musical timebase before changing the tempo.

To me the Tempo of that musical piece is not 169 more like 105 and variable
Try tempo mapping it to see



Not sure which tempo it was recorded at but not either 169 or 147. When I import it I can speed it up or slow it down according to the Tempo I set but it looks to me that the problem is that it has the wrong tempo information recorded into the file (recorded free-style without a metronome?).

Thanks for your help, the tempo looks to vary a bit … it comes up as 70ish bpm for me.

How do I change the midi to musical mode?

You can´t change MIDI to musical mode.

I had to change the track control settings to get the timebase icon, a musical note, is that what you meant ‘musical’

“Musical timebase” - yes. That´s different from Musical Mode, even if some members will try to tell you otherwise.

Ok so thanks for everyones help, it seems the solution is to detect the tempo of the midi and then change it to follow the required tempo.