Can't get Cubase to see USB keyboard for MIDI

Hey all,

I’m very frustrated trying to set up Cubase with a USB keyboard. Here are the details:

Cubase 7.5
Windows 7
Oxygen 49 Keyboard / Graphite 25 Keyboard

I plug the keyboard into the fully functioning USB port, and it powers the keyboard.
I launch Cubase, and they Keyboard shows up as a MIDI in option
On the Device Setup list, the keyboard shows as “active” and “visible”
I assign the MIDI in of a track to that MIDI in (or to All Midi)
Monitor is on.
And – nothing. Zero response from the program. No MIDI input on the meter, no notes, no sound.

TWICE I have seen the keyboard control the music, I saw the incoming MIDI signal on the monitor, and I was able to play. I don’t know how I got there or how to get back. I’ve tried new projects, old projects, everything I can think of.

I’ve tried to set up a Generic Remote as well, and when I check “Learn” it does not respond to the keys either. It’s very much as if the computer sees everything about the keyboard except the MIDI signals.

I was originally doing this all with an Oxygen 49 keyboard, but also now with a Graphite 25 to see if that was the problem.


I’m certain I’m missing something very basic, but in all the text and tutorials I see on this, they basically say, “Plug it in, and it works - so here’s the next steps…” But the first step doesn’t work for me.

I’ve searched a lot of this, but the terms are so general that I haven’t been able to find my specific problem.

Any input is very welcome. I’m generally computer savvy, but clueless on Cubase.

Thanks in advance!

Barry

Make sure the keyboard is set to “local on”, then make sure to choose a VST instrument and a vst sound.

Regards. :sunglasses:

Also the track you are routing the MIDI Input to has to have the Monitor button enabled for the VSTi to make sounds based on what’s coming from the MIDI Input. If it is disabled then the VSTi will play the MIDI data recorded on the track.

Thanks for the responses.

Yes, the keyboard setting is local on.
Yes, I have an instrument assigned, and yes I have the monitor on.

Again, I do not see any MIDI data coming into Cubase. I believe that if I had the monitor off, or a track unassigned, I would still see the MIDI input “meter” showing the MIDI coming into the system, I just wouldn’t be using it.

When I look at tutorials for this online, as soon as they plug they keyboard in, they get metering on the MIDI input, and the tutorial is about what to do with that data now that it’s in the system. I don’t even have that.

You are correct you should see activity on the MIDI indicator if the data is coming in. So it is likely upstream from Cubase.

Perhaps this might help.
http://www.musicrepo.com/testing-midi-device/

Well, I’m happier now, but still baffled.

I ran the utility - thanks. In it, I opened up the MIDI device and tested it. Everything worked well, I saw the MIDI signals, I heard the piano.

THEN - I went back to my Cubase project, and everything worked fine. It saw the MIDI signal, it let me play and record. I opened up another project, and it worked there, too. No changes. I rebooted, and it still worked.

I have no idea what changed, but it suddenly all worked.

Then, playing around with it - a key got digitally stuck. I had to close the project to get it to stop sounding. After that - nada. No more MIDI.

I went back to the testing app, repeated the process, and it’s all working again.

I’m baffled, but at last I now know how to reset it if it stops working again. I hope.

Any guesses from anyone on what that means what happening? And how to fix it longer term?

Thanks again - made a huge difference.

Until you get it sorted out try sticking the MIDI Monitor on an insert for the tracks you are using. Then if you run into stuff like the stuck note you’ll be able to examine the midi stream leading up to it.

You might also try swapping out your cable. An intermittently bad cable can seem good until it isn’t.