Cant get hardware to connect with cubase

I recently purchased an Alesis Multimix 4 USB FX and i can’t seem to get it to work with Cubase. I am using a MacBook Air and my Multimix came with Cubase LE 9. When I try to set the device up and go into the VST connections window my device shows up connected in the outputs tab but not in the inputs tab. When I click where it says not connected under the devices column it gives me the option to select my USB Audio Codec as an input but when I do it doesn’t do anything. It just continues saying not connected. What am I missing?

Hi and welcome,

Alesis relays on Class Compliant Driver. Can you see the inputs in other application? Can you see it in System Preferences > Sound > Inputs?

Yes I can see it in system preferences. I even downloaded garage band and it worked just fine.

In this case it seems there is an issue with the CoreAudio2Asio component.

What macOS version do you use?

Osx sierra 10.12

This shouldn’t an issue, this is official compatible.

Could you try to make an aggregate device (with your Audio Devices inputs and outputs) in Mac OS and try to use this aggregate device as your ASIO device?

How would i go about doing that?

Use macOS Audio MIDI Device utility, please.

In the Audio part, on the left side, create Aggregate Device.

ok that did the trick. I got the aggregate set up and can now uss it to record with cubase. However i ran into another issue. When im recording it is fine but then when it is played back it cuts in and out and sounds all crunch and staticy. Any suggestions?


Try to increase the Buffer Size, please.

That didnt seem to help. If anything it makes the vocals sound more robotic.

How does it sound, when you Export Audio Mixdown and play the exported WAV file in any player?

I havent even gotten to the point of trying to export anything because it just keeps giving me this loud buzzing when i try to record and making the vocals sound robotic. I will try though.

I just exported a small chunk of vocals as a test and it sounds exactly as it does when i monitor and/or record it.

So with the issue, right?

Can you upload somewhere (like Dropbox), and share the link here?

I think i figured it out. I delted my original aggregate device and ended up creating another using my alesis multimix 4 as the input device and my built in audio outputs as the output device and it seems to be working.

Yes, this was the idea to use your multimix in the aggregate device.

I’m glad it works to you, now.

Yes i did that the first time but i had set both the multimixs inputs and outputs in the aggregate device which i think was what the issue was.