Can't get rests to disappear

I’ve got some erroneous rests showing up in a percussion part that I can’t get rid of. I tried changing their opacity to 0%. I checked that they were indeed implicit rests (they are). I played with checking the ‘starts voice’ / ‘ends voice’ options on the notes in the measure, still no dice. Anything else anyone can think of to try here? Thx a ton!

To quote John Barron, on the Dorico Facebook group, 13 hours ago:

“Remove rests doesn’t apply to drum kits. Instead select the notes, right click and use Percussion > voice > extra upstem voice (or similar, I’m not at a computer right now)”