Can't get UMC22 to work with Cubase LE AI Elements 10

I just purchased the Behringer UMC22 and downloaded the driver for it. I assigned the driver in Cubase, but can’t hear audio through the device and also can’t send audio through it. Does anyone have any ideas?

System: Windows 10
DAW: Cubase LE AI Elements 10
Audio Interface: Behringer UMC22



Is it an ASIO driver, please?

Read the Cubase manual and set Up as explained there.

Yes, the driver is ASIO4ALL v2.

I finally got the guitars figured out and am able to record those. I looked at the Cubase instructions online and went through a bunch of stuff. For some reason I thought it would be easier than this, haha.

However, I’m still having issues with the microphone. When I record, I can see a little bit of movement for the sound wave, but very little. When I play it back, there is still no audio coming out. I have the phantom power turned on on the UMC22.

Any ideas for the microphone?



What microphone do you use? Did you set the Gain up?

While playback, make sure the Monitor button is switched off, please.

I’m using a MXL V63M Mogami condensor mic. I turned the gain all the way up and still nothing. For kicks, I tried a dynamic mic and can get some sound from that, but it’s as if the gain as down pretty low because it only pics up loud sounds. However, the gain is all the way up on that too. The monitor button on the interface is off. Is there another monitor button to switch off or something like that in Cubase?



There is Monitor button on the track in Cubase.

Thanks. I checked that and it is off. I then recorded both with it on and off and I get the same result - no audio is recorded.


Do you have the right input selected in the track?

I’m not sure exactly what you mean on that, but will look when I get off work today and see if I can find anything like that.

Thanks for your help!


What input do you have selected? And where does the input come from (Audio Connections > Inputs)?

I’m not 100% sure on the inputs and outputs. In fact I’ve been trying to figure those out. I did get the guitar working, just can’t get the mic to work properly. Below is a screenshot of what I have for the inputs. I have the track selected and it records on it, but no sound comes from it on playback (no sound waves show on the recorded piece either like you would expect).

WHOOOOOAAAA, WTF. I just went into the channel settings (the “e” on the track) and messed around and got it to work. I changed the input on that screen to be something different and it immediately started working. I appreciate you helping me through the troubleshooting steps. Sorry for the basic questions - the last software I used was the original Cubase back in the early 2000’s so it’s been a while, haha. Thank you!!! :slight_smile:


I’m glad it works for you now.