Can't hear effects while playing

Hi,

I have Cubase AI 9.5 and Steinberg UR242.

When I add a audio track and record my base I can hear my self playing direct, but I can’t hear the effect (inserts) while playing, I can hear after on the recording.

How do I get to hear the effects while playing?

Thanks

Benjamin

How are you monitoring during recording?
Where are the effects inserted, on the Input Channel or Track?

Disable direct monitoring.

Hi,

The effects is on the track. Disabling direct monitoring did the trick. Thanks so much !!! :slight_smile:))

HERE’S HOW: try unchecking the “Direct Monitoring” option here:
Studio–>Studio Setup–>Steinberg UR44–>Direct Monitoring
If unchecked, you can hear your instrument and voice
If checked, you cannot hear yourself regardless if you turn the orange speaker button on or off.
SEE ATCH SCREENCAP.