can't hear what I'm recording on instrument track

hello,
I am noob to Cubase. I have Elements 10.5 wich runs on a Steinberg UR-RT2 interface and a Nektar Panorama P4 master keyboard.

I don’t have any issues with audio but I am struggling with VSTi’s

my keyboard detect smoothly the tracks I add but when I try to play a VSTi, let’s say halion, I can’t hear what I’m recording whereas it’s sounding when I playback the recorded track. :confused:

I have tried with or without the little speaker lit on but it doesn’t change anything.

this is very frustrating :unamused:

I forgot to tell I am on MacOs High Sierra, latest update.

Make sure, in preferences -> “MIDI-thru active” is active, and “MIDI Filters”->“thru”->“Note” is not active.

I can’t tell you right now cos I have left the studio
but I will tell you tomorrow asap.

what does midi through do?

(I work mainly with bitwig studio and digital performer but I’d like to switch on cubase for collaborative intentions)

yes, midi through is active and disabled in filters.

at this point what I don’t understand is why I don’t have sound while recording but I have it in playback…

Do you check the monitoring button (little brownish speaker button)?
If this is enabled you will hear what you record, if this is NOT enabled you will only hear the recorded track while playing back.
The handling of this button is also influenced by vst programm settings (“Tapemachine style”, etc…)

Just guessing.

issue solved with the help of steinberg customer service,
I had to reinitialize preference.

Also try unchecking the “Direct Monitoring” option here:
Studio–>Studio Setup–>Steinberg UR44–>Direct Monitoring
If unchecked, you can hear your instrument and voice
If checked, you cannot hear yourself regardless if you turn the orange speaker button on or off.
(See atch image)