Cant Hide Staff

Im doing a sketch chart…at the beginning is a Tenor sax for 8 bars. I added the ‘solo’ player Tenor Sax to my part. after the 8 bars I do not want the empty bars of the tenor part to show - but I am unable to hide it. I select 1 bar and then go to Staff - Remove staff but nothing happens… I have tried selecting a number of bars and doing the same but nothing happens?
In Sibelius I just selected hive empty stave and it was done… is this option not available in Dorico? If not how do I hide the sax part other than the first 8 bars?

See here.

Hi Daniel, That did not work the Tenor sax is still there?
Anything else?

Typically Hide Empty Staves will work as long as you’ve selected the correct Layout in the right panel of the dialog.

If that doesn’t work, please zip up the project and attach it to this thread so someone can take a look.

Here it is…
Hold back the (623 KB)

I have also tried selecting a bar and right click then select remove staff = nothing

I’m away from my desk just now but if nobody else has resolved within half an hour I’ll get onto it.

Andy, on the Vertical Spacing page of Layout Options, you have activated the checkbox for the tenor saxophone player in the list of players for whom empty staves should not be hidden. Uncheck that checkbox and you should be all set.

On a separate note, Andy may I ask why you’ve deleted both instrument names for the guitar? If it was so that you could show staff labels where the saxophone is but hide them where there’s only guitar, there might be better ways to do that (such as by changing your default staff label settings to the one that fits most systems, then inputting system breaks and changing the staff labels at those breaks where you want something different)

Thanks Daniel :slight_smile:

I delete the names so it doesn’t take up any more space on the left of the page. Te instrument names are not important as its just a lead sheet…I indicate in box text should a certain instrument is required.

In that case, the quickest way of hiding staff labels is via these settings in Layout Options: