Can't hide stave

I’m doing a leadsheet booklet in wich I need to hide stave.
I use a piano staff and i have no problem hiding empty stave by using the Layout Vertical spacing.

However, it doesn’t seem to work when a third staff has been added.
I deleted the extra stave from the location it’s no longer needed but even then, I’m stuck with 2 staves for the remaining of that flow.

Is it possible to hide unused staves in this context?
(I double checked to make sure no hidden material could prevent the stave to hide)

Have you checked the option to “Allow individual staves of multi-staff instruments to be hidden” and that any player is excluded from hiding, as in the attached screenshot?

Yes. I use a single layout for all 6 flows and the problem appears only in flows that includes extra-staff.
I was looking for hidden text objects or something like that but nothing on that side neither.

From the version history document:

Hiding empty staves. When extra staves are added to an instrument, it will no longer be affected by the Allow individual staves of multi-staff instruments to be hidden option on the Vertical Spacing page of Layout Options.

I was hoping that once the extra stave was removed, the remaining would resume as if there was no extra stave.

Would like to see this behaviour to keep all staves within the same bracket.