Can't hide staves in first system

Attached is a snapshot of two pages of a score where I have selected “All systems” under “Hide Empty Staves”.
Empty staves in the first system are not hidden, I’ve tried to attach the project but at 7 Mb it is too big.
Any ideas?
Score.tif (627 KB)

Was your score imported by MusicXML?

There is a problem that some other notation apps generate explicit clefs at the start of each staff in the XML file, even if they are the same as the default clef for the instrument. Dorico then thinks there is some notation on that staff (i.e. the explicit clef) and hence doesn’t delete it.

Try selecting the clefs on the empty staves and hitting “delete”, and see if that hides them. They clef won’t disappear on the following systems, because Dorico knows what the default clef should be.

Thanks so much Rob! I have been having this issue with some xml imports; deleting the first clef does the trick. And thanks Mmayson for asking, I’ve been meaning to ask the same thing.

Just a comment: .TIF isn’t a very friendly graphics format to use on the web. With some browsers, you have to open a separate application to view .TIF files. .PNG is a better option to use.

Good one Rob! That’s the answer alright.