Can't Import Midi Files into Cubase 10

Hi folks,

I’m using Cubase 10 (Mac Mojave) and for this specific issue, I am trying to import MIDI files created one a Korg Kronos 2 into Cubase, I have tried saving 4 different variations.

Type 0 without exclusive (assuming this is something proprietary to Korg)
Type 0 with exclusive
Type 1 without exclusive
Type 1 with exclusive

Unfortunately none of them seem to import into Cubase at all using File > Import > MIDI file > and either create/don’t create a new project.

Has anyone else had issues with this or perhaps someone can offer advice?

Thanks,
Anthony.

Exclusive is just an exclusive data packet for the Korg, basically all the Global settings, Programs, Combinations, midi global channel etc.

Type 0 is everything on ONE track
Type 1 is separate tracks for each midi part in the sequencer.

How are you trying to import them into Cubase? How are you SAVING the SMF in the Korg? Are you saving to USB, HD computer etc? Last time I looked Korgs file format is proprietary

What Im sayin is the file saved in the KORG HAS TO BE a standard PC or OSX file format using .mid
Which is the KORG is probably a PC file format and you are trying to import that into an OSX OS

.MID files
Saves a Sequencer mode song in Standard MIDI File (SMF) format.

OH, one more thing, on the KORG, make sure there is nothing disabled on the TRACK themselves as far as exclusive or midi

  • My Triton here saves in DOS format to HD Floppys!! Cant use in Mac or PC without some translator app.

Hi thanks for the info.

Yeah I am saving the files to a USB on the Korg, then copying them off the USB onto my Mac.

I thought SMF and MIDI were the same, but I’ll look for a convertor.

If you want me to try here all I need is the .mid file. Glad to check it

You can probably post it on this thread if you want as an attachment
or
shanabit at yahoo

Hi Shanabit,

I found this video on YouTube which solves the problem another way:

https://www.youtube.com/watch?v=2SbVxe-YZiQ

All sorted.