Can't increase buffer size - please help!

Hello all,

I’d be grateful if you can help. I’m running Cubase 6.5 with a Presonus USB, with the latest driver installed. I want to raise the Buffer size to (at least) 512, because currently there are too many pops and clicks. However, when I go to Device Setup and click the driver control panel button, nothing happens. Worse, when I go to the Presonus control panel outside of Cubase and change the buffer size there, Cubase then fails to recognise the driver at all, and there is no sound! What in the world is going on?!

I have uninstalled/reinstalled a few times and the same problem keeps occurring.

Many thanks in advance for your help or suggestions!


Cubase 6.5 (32 bit) - Windows 7 64-bit - 6GB RAM - intel i7 2GHz

maybe there is a bug with the latest driver or could be the wrong driver , can you roll back to an earlier driver ?

Close Cubase - open Presonus control panel - Change buffer size - then re-open Cubase…?

Thanks guys, I really appreciate your help. Unfortunately, the problem persists!

I tried closing Cubase, then changing the buffer size. When I reloaded Cubase, not only did the driver fail (as expected) but also the Halion orchestra failed to initialise, saying my licence had expired (it hasn’t, honestly!). I then went back to 256, and the Halion initialised but the driver still failed, so I had to uninstall/reinstall yet again.

I also tried rolling back to the previous driver, but that also failed to work. Literally the ONLY thing Cubase will recognise now is a freshly installed latest driver in which the buffer size has not been amended.

Something is SERIOUSLY wrong here. As you suggest it sounds like a bug, but I don’t know whether it’s Cubase or Presonus (or both!).

Any further suggestions greatly appreciated!


you say you have a licence failure have you got the latest version of the elicencer installed ?

what is your OS and hardware?

you say you have a licence failure have you got the latest version of the elicencer installed ?

Yes. The Halion thing sounds like a wierd knock-on effect of the main issue, I couldn’t begin to guess why that happened but it only happened the once, so touch wood it won’t be a problem again.

what is your OS and hardware?

Windows 7 64-bit, Toshiba Laptop PC, intel i7-2630QM CPU @ 2GHz, 6GB RAM.

Check your usb connections and your usb drivers as well.