Can't install C12.0.10

Win 11.

The installer starts up, the green bar begins to move, then it shuts down. No message, no idea what’s going on.

On my Computer it works fine.

That’s great to know.

I tried uninstalling C12, but now I can’t even get C12.0.0 to install.

I’m dead in the water.

If you can give more granular details, maybe you can get some answers.

What details can I give? I’m using the Download Manager - it downloads, verifies, runs the installer, then the installer just shuts down. No more to report. Now the original C12.0.0. installer does the same.

I don’t know, but

you don’t mention what happened then, did it uninstall? Have you restarted the machine?

Yes, it uninstalled and yes I re-started the machine.

Maybe download from the web site, look for Steinberg Downloads and try doing this without the Download Assistant.

Tried that too - no dice.

I’m going to try simply copying the Cubase 12 folder from my laptop, where the update has installed fine. It’s worked for other Steinberg installation failures…

Yup, that’s worked. I have a feeling I’ll be doing this every time until I replace my desktop PC now. If nothing else this report may help others.