Cant install Cubase 9.5

I went to the Steinberg Download Assistant and downloaded the program. When I open up the folder I saw a Cubase 9.5 type folder in my Zip folder.

I double click on the Start Installation.exe and nothing happens. I turned off my Norton anti virus program and still nothing opens. There is a Cubase for Windows folder but none of the exe folders open.

So I deleted the files in the Steinberg Download Assistant and downloaded the program again. When I go to the Start Installation.exe file and double click, nothing opens. I even moved it to my desktop and right clicked it and said open and still nothing happens.


I am on Windows 10 64 bit with I7 Intel with 16 gigs of ram. I currently was running Cubase 8.5 with no issues. I did go to the Elicense Control Center and was able to update my Cubase 8.5 to Cubase 9.5 with the activation code.

Did you unzip the zip file first? You can just drag and drop the files to do that.

I got it to work. Winzip did not open it properly. I used 7-Zip and that did the job.So far really liking 9.5

I updated the Elicenser Control, even cleared the program as well as maintenance as I am getting an error message.

Eicencer Control Error
Application Unknown Application has caused the following error:
Application not registered

Options: Click ok to abort.

The Status bars in the Download Assistant have been oscillating (blue tracer back and forth) for what seems forever. The files in my download folder appear as shown. How do I get this situation unstuck so I can open Cubase 9.5?


Try closing the download assistant, then run it again and make it download Cubase 9.5. If there are no errors in the downloaded file, it should resume from where it left off.

I have tried that several times. Each time the SDA goes back to the oscillating Status bar. Should I trash all CuBase dowloads and start again?

BELAY that: the status bars finally just turned green. (Whew!)

CuBase now installed, but no sound on the CuBase demo project (even though sound still works in Dorico) and I get a message that AppSimPro is trashing my license registration. Have filed a support case and hope this can be solved soon.

Press F4 to map your audio outputs.

Derrek, I am having a similar issue;
It would be greatly appreciated if you can elaborate on how you fixed your problem. Thanks.
Minseo Park