Cant install Elements 8 (Mac Trial Version)

HI, I just tried to instal the trial version but i get a message telling me I can’t install because I dont have the latest version. I’m running Yosemite 10.10.4

The message says I need at least 10.6.0…

Is this a known bug?

Thanks

Ben

What version of Cubase are you trying to install? Cubase Pro 8 and Cubase Elements 8 should install on 10.10 without any additional help. But if it is an older version of Cubase, you may need the 10.10 installation helper http://www.steinberg.net/en/support/content_and_accessories/content_and_accessories_sait.html

I’m installing the latest trial version of wavelab elements 8, not cubase

For Wavelab Elements 8, you can install with 8.0.5 from http://www.steinberg.net/index.php?id=8834&L=1

It installed no problem until I started the program and I got a licence error (see attached image).

Is the link you provided for the trial version? Feels like we’re going round in circles :slight_smile:

Ben
1.jpg

OK, I think this is what I need: http://www.steinberg.net/en/support/content_and_accessories/content_and_accessories_sait.html

It looks like, unless you can provide me with a solution, the trial version is not compatible with Yosemite.

If you can answer this, as per my private message to you, maybe I can skip the trial and purchase elements 8:

"I actually dont mind skipping straight to purchasing the product but the specification is a bit vague about a key feature I use; markers. In the specs, it says something like ‘limited functionality only’… who knows what that means…

I basically, for example, cut, copy and paste parts of waveforms - all using markers. Thats pretty much all I use it for. Mostly editing DJ mixes or making my own edits of songs, medleys, etc…

Anyway, I hope you can help as I’m a full time event DJ and could do with being able to use it immediately."

Thanks for you help

Ben

One thing it means is that there are no CD track markers - CD layout is done differently in Elements from how it is in full WaveLab.

Paul