Can't Install Library Manager after Deleting Cubase Pro 12 and Reinstalling

Hey Everyone,

I thought I had some issues with audio dropouts in Ableton Live after I tried going to Cubase, so I uninstalled Cubase along with all of its registry components to see if it fixed it, and it apparently did so (maybe it was just a correlation).
Nonetheless, I tried to reinstall Cubase Pro 12 afterward and I got this error message:
"Could not write value to key SteinbergLibraryManager.Document\shell\open\command…
Verify that you have sufficient access to that key, or contact your support.

I tried checking the registry for any leftover Steinberg keys and didn’t find any in software under Users and Hardware. There are also no Steinberg programs under the control panel or in CCleaner if trying to uninstall from there.

Could anyone provide some ideas on what can be done?

Most software installs components and shared libraries that don’t include the company or product name, so you can’t look for them in the registry, but that’s what it sounds like you tried.

Then you deleted entries without realizing that they pointed to the location of other entries, and now your registry ‘cleaner’ has no way to know what’s in there.

Now it’s broken.

The fastest thing to do is reformat your hard drive and start anew.

You also might try running the installers of each program Steinberg installs for licensing etc., have a search on the Steinberg Support site for that info.

Or you can try use a utility to inspect the installers themselves to find some hints on what to look for in the registry.

Hey there, sorry for the late reply.

This seems quite unlikely that I deleted components pointing to other components as I only deleted Steinberg components that were not there before I installed the program. It was as if I started with a clean install, right? As when you first install the program you have no registry entries, thus, that’s what I started with upon the reinstall.

Reformating the hard drive is way too much for something like this, I will try to contact Steinberg and see on their support pages if I find something as this seems to be quite a big problem for just deleting some registry entries that were not there prior to the first install anyways.

Thanks for the tips though!

What kind of utility are you talking about? Can you send a link to the actual software or the name you’re referring to?

I was referring to registry entries:

A utility like 7zip lets you inspect the contents of certain installers