Can't login to MySteinberg

I´ve got the same problem. Cannot log in to my account. (and not able to request support).
Please help me here.
Thank you.

Hi,

Yes, I’m having the same issue here.

I can’t log into my Steinberg Account, also requested new password, but no email has been received, also checked my spam mail, nothing there.

Maybe Steinberg is performing some maintenance, or something else to the MySteinberg system ? or … ?

Any feedback on this would be appreciated.

Can other users test if they can log-in without issues into their MySteinberg Account, and report here.

Thanks,
Muziksculp

OK.

I just received an email form Steinberg with a new Password, so I’m able to login now.

I’m glad this is fixed, but I have no clue why I had this issue in the first place.

Cheers,
Muziksculp

Requested new password on login page. Did not accept username on request, but e-mail worked.
Logged in again :slight_smile:

There’s something going on over there. I don’t know if it’s an incompatibility with my version of Safari, but for whatever reason I have trouble logging in too. I guess it’s time to update my browser.

Some days ago I couldn’t log in with Firefox, now it’s ok…

But anyway they don’t respond to my support request / question… :cry:

Happening with me as well, won’t accept password which I have not changed. Am trying to register some new programs, very frustrating. Is this an ongoing problem?

once I updated Safari, everything seemed to work fine for me.

I had the same issue with the password.

Turns out they’ve changed the system to require 8 characters for MySteinberg now, whereas my old password ( that I’ve used for years ) was 6.

This Forum hasn’t changed so I’m still using the old password here.

Yeah, figured it out as well, was reluctant to change original password but finally got in when I did.

Hi.
When I try to login to my account I got the message “wrong username or emailadress”. When I ask for a new passvord it is sent to my old emailadress whitch is not working anymore. How can I change my emailadress without being able to login?

Hello I have a problem to login to with my trusty login and password. But I’ve changed my domain with email addres so I can’t resent the password. what is going on?

Same problem here…
Please help me.

Same problem here:/
I created new account, but when trying to register eLicenser that contains all my licenses, it gives me a message that it’s registered to another user:/
Please help…

And for me the same!

Like Paul Bryce wrote:

Turns out they’ve changed the system to require 8 characters for MySteinberg now, whereas my old password ( that I’ve used for years ) was 6.

And:
This Forum hasn’t changed so you can still use the old password here.

Thanks for the info Paul!

i have the same issue - no access to my steinberg account.
did not receive any password recovery email either.
My elicenser CC shows all my licences for Cubase 5.5, WL7, Arturia, Wavelab LE8. and even going through it (Registration / register all…) my steinberg does not recognize my username nor email.

i am considering upgarding to Cubase 8.5 but without access to my account would that be possible?

i can upload my USB key number if required by moderator.
please help me out with this mess.

best, brane

Same issue here - can’t even reset my password as it says I have to activate my account first, but as I can’t log into it, how can I activate it…

Can’t use the Contact Steinberg Support form because (guess what) it’s only available via mySteinberg.

I get the same problem.

I can’t login and I can’t change my password as I got a message that my email address doesn’t exist!

I used Safari and Firefox without success.

Please post to the forum relevant to the program you use. This 5 year old thread is not the right place.