Cant play groove Agent drums on the pads of my Launchkey MK3

I am still very new to all this, but I have managed to map my Launchkey MIDI to work with Cubase 13, but when I open plugins like Groove Agent I can only play the drums on the keys, but never on the pads. Obviously there has to be some function in the MIDI mapping that allows to switch the pads to instrument mode, but, for the love of God ,I can’t find how to do it! :sweat_smile:
Perhaps this should be done on the Launchkey itself?
If anyone can enlighten me, please help!

I have Launchkey Mini MK3. If you open the Novation Components page ( in Microsoft Edge, and navigate to custom mode settings, you can set, and download to your Launchkey, individual MIDI notes and channels to your Launchkey pads. AND you can set each pad colour too.
So say, on the Components page you set all the Launchkey pads to Channel 10 and for each pad set the MIDI note to correspond to the note of the pads within Groove agent (also set on ch10), then you can play Groove agent pads on the LaunchKey pads and something else (like Halion) on the Launchkey keys set to a different channel.
Works for me anyhow.

Thank you so much! I followed the link you gave, and there I found two solutions: either download “Factory pad custom mode 2” which apparently works with Groove Agent,
create my own custom mode (which is what you were describing) where I could choose the colors of the pads and which one goes where.
A note to anyone who is as green as me and reads this in the future - when you are customizing your pad mode you have to change the “message type” to “note” - that is when you get the windows for choosing the notes and octaves (Groove Agent pad commands are all notes like “C#1” for example). Then pick “channel 10” under “MIDI Channel”, choose your pad light colour (at the very bottom of the choice scroll window) and you can even decide if the pads will pick up velocity or just hit full strength every time (I did a separate custom mode for with velocity and without!). Then you press “send to Launchkey [MK3]”, and choose which custom setting to override (there are 4 different ones, clearly empty to begin with). Then on your MIDI keyboard hold the “shift” button and press the pad corresponding to the number of your chosen custom mode (the bottom right four pads are the custom mode choice ones) . And voila! It worked for me.
Thanks again @bloodline1 , you showed me the way to the oasis! :desert: :smile:Everything is working beautifully!

1 Like