Can't Prevent "Adjust[ing] for Record Latency"

As in Cubase 8.5, having the “Adjust for Record Latency” checkbox not checked
Adjust for Record Latency Checked.jpg
doesn’t stop Cubase from adjusting for record latency.

To reproduce this, play back an audio track through an audio interface while recording a looped back version from the interface on another track. Do one recording with the box checked and another with it not checked. There will be no difference in the timing of the two recorded tracks with respect to their respective playback tracks - showing that the checkbox state has no effect.

I resubmitted this with added details to get it in the bug report folder https://www.steinberg.net/forums/viewtopic.php?f=254&t=111022