Can't record external midi sound to audio in Cubase 10.5.12

Hi everyone,

I’m new to this forum, and I was wondering if you could help me out.

I am using exactly the same settings as I did with Cubase 10, but I can’t seem to live record my external Korg N1 sound (but I can hear it) in Cubase 10.5. In Cubase 10, all I had to do was create an audio track, solo it and the midi track (with the audio track selected) and press record and it would record in real time, but when I try to do the same with Cubase 10.5, I just get a blank audio file (see screenshot).

I noticed that I can hear the external midi sound, but it does not appear on the meter.

In MIDI preferences, I have ticked record-enable allows midi thru, and in the MIDI filter section, I just have SysEx ticked for record and thru.

I’m using a Mac Mojave 10.14.6 on a late 2015 imac with Scarlett 2i4 audio/midi interface (it allows 2 audio inputs, and 4 outputs).

Thanks in advance.

Hi and welcome,

Could you double check your Audio Connections > Inputs, please? What Inputs are assigned to Stereo In? Is it the input you would expect (your Korg is connected to)?

Hi Martin, thanks for replying.

Inputs 1 & 2 are assigned to stereo in and this is the configuration that worked for my Korg in Cubase 10. (There are only 2 inputs available on my interface.)

I also tried setting up my Korg N1 as an external instrument, but both stereo in and the external instrument need the same device ports (input 1 & 2) from my audio/midi interface and cannot be assigned to both at the same time. I’m not sure if this is relevant or not.

I guess the main point is that it all just worked in Cubase 10.


Isn’t the Stereo In channel muted in the MixConsole by any chance?

When you enable Monitor on the Audio track, can you see the incoming Audio signal (when playback), please?

Hi again,

The Stereo In channel is not muted (see screenshot below).

However, when I enable the monitor on the audio track (in the same set up as the screenshot), I can’t see an incoming audio signal when I playback the Korg midi track.

And when I try to record, I get an empty audio file.

  1. Your Orchestra Hit Audio Track needs to have the MONITOR button turned ON if you are recording through Cubase. IF you are recording through the Scarlets software console then raise the FADER in that app for those audio inputs and leave the monitor button on the Cubase track turned OFF

  2. Studio Connections Input Buss Tab you should have a STEREO INPUT with the correct physical input ports selected on your Scarlet


That’s not quite true. The Monitor doesn’t have to be enabled, when you record. It has to be enabled, when you want to hear what you are recording through Cubase. But you can record even if the Monitor button is disabled.


To me it looks like the Input is not set properly. Could you please once again double-check Audio Connections > Inputs? Could you attach the screenshot of this window from Cubase 10 and Cubase 10.5, please?

And just for sure… Could you try in Cubase Safe Start Mode [Disable preferences], please?

Hi guys,

Thanks for your suggestions. I still get that empty audio file whether I have the monitor button enabled or disabled on the audio track.

Martin, here are the audio connection inputs on Cubase 10 and Cubase 10.5 respectively:

I followed the youtube link for starting in safe mode. However, I have to embarrassingly admit that I couldn’t do it! I pressed com+shift+alt on my mac when the splash screen starts and it took me to a dialogue box which said Cubase Open Document Options. Tried it several times. Thanks for your patience!

Semantics. The assumption is he wants to hear what the hell is going on as well before hitting that RECORD button. I know I do. :sunglasses:

If you are recording THROUGH Cubase and want to hear what you are playing before you hit the record you will need to hit that monitor button

I never have the monitor button on to hear anything as I use the MR Console Software
Carry on

FYI: On my Scarlett 2i4, when I turn the direct monitoring knob to input I can hear the Korg orchestral hit, when I turn it all the way to playback, I hear nothing.

I have record-enable midi thru ticked in my preferences.

I also started in safe mode (pressed keys before splash screen), and disabled preferences. Still recording a blank audio file.

Thanks for your help. You both pointed me in the right direction, and I have the solution now!

I had to go to my security & privacy settings on my mac. The microphone was enabled for Cubase 10 but not for Cubase 10.5, so I just had to enable it and it all works fine now! Yay!

Man I hate all that invasive OSX crap now, used to be SO simple

Yep, I hear you!


Oh no. This one again… Sorry that I didn’t come to it.

It wasn’t easy to spot as it was something outside Cubase.


Yeah, but I know the issue very well. I even have a template for the post how to fix it, here at my computer. But you remind it to me, so when it happens next time to someone, hopefully it will ring the bell. Thank you. :wink:

Had the same issue… 10.5 had no external audio in, but was working in 10… This was the fix!