Can't record pc sound output (Elements 8)

Hello all - I’m new here and new to Wavelab Elements 8

I have just installed Elements 8 on a new Windows 7 64bit installation and have tentatively tried to record the PC sound output.

I can’t get it to see any sound from the Realtec HD on-board audio even though I have turned on sound input sources within RealTec. To test it I have tried Media Player and streamed broadcasts as audio sources.

On the same PC, which still has XP Pro (dual booting option) and with the old Wavelab 5 installed on that, I don’t have any problem recording sound outputs from the same Realtec HD audio output. I appreciate that the drivers will be different for W7 but this shouldn’t affect audio out, should it?

Is there anything which I might have overlooked in the setup? I’ll try a microphone and midi input tomorrow but I don’t think it will make a difference - something appears wrong. Any ideas please?

I get an error as soon as I try to enable Monitor in ‘Record’ suggesting sound card may not be correct rate/bits - but it is, and is capable of detecting and using any set rate/bits with the Wavelab 5 installation.


PS: Disappointed that Elements shipped with virtually empty box and no printed manual!!

rgds,
lowtech
UK timezone.

Hello, try: Options > VST Audio Connections > then chose Windows MME in the dialog box.
Hope this helps.

Hello Marco - MME is the only option in VST Audio. Under Recording Options is only Microsoft Sound Mapper. Still no joy here.

On ‘Monitor’ Err msg is : " Cannot open Wave device for recording. Are you sure your audio device supports the currently specified sample rate and/or bit resolution? Check also if the input of the audio device is in slave or auto-sync mode."

I have tried lower rate/res. with no effect. Is slave/auto sync relevant? Where can I check or set it?


Is there any thing else to try please?
thanks

MME is the only option in VST Audio

This means there is no ASIO driver for your hardware. Try to find one.

If there is no ASIO driver, then look into ASIO4ALL.

Paul

Thanks for the suggestions, all.

I spent some time today trying to work it out logically. There was no ASIO - only MME. I searched this and came across Asio4All and installed it: it was then available to select in VST settings.

There were various outcomes

(1) I could now open Record and select Monitor.

(2) I still could not ‘see’ any sounds from any inputs - there was just constant -36db ‘noise’ showing on Left channel only. No settings in the Sound setup and asio4all enabled getting the sound recordable. One setting actually caused sound overload on Monitor again on Left chan only??

I spent about 2 hours with more fiddling and googling and found a tip on proboards.com to turn off all exclusive access on all sound devices - where there are also some instructions on asio4all - still didn’t work…

Until I selected MME again in VST setup… i.e. Not ASIO. :confused: It all suddenly sprang into life and I can now record from any sound source BUT NOT using (not enabling) ASIO4All.

Problems obviously due to a load of conflicts and resource grabbing.

So do I need ASIO for Wavelab at all? When do I need it? I thought it was essential for certain effects/synchronising etc.

Still Confused…

Wavelab E8 now working with either MME or Asio4All.
I notice that Cubase E7 comes with included ASIO device but this doesn’t show up in Wavelab settings.