Can't register C6

I loaded up C6 from the installation disk, seems like everything went OK. I can open C6 now, and it doesn’t say “you have X days left of your trial”, so I’m pretty sure the installation went OK. I never did register my C6 Trial, if that was even possible - I just kept hitting “remind me later” when it asked on opening.

I tried to register my new “full” C6 in two ways, unsuccessfully for each:

  1. As on the “quick start guide” that came with the box, went to http://www.steinberg.net/register. It brings me to a (German) 404 website.

  2. I hit the “Register Now” button when I opened Cubase 6. It brought me to a page that said it “will register all the products on my USB e-licenser” (which of course has C6 on it). I typed in my USB elicenser # in the field, and my name - but when I hit “enter” it gave a message that made no sense to me: “You cannot register this product for the following reason: You have registered your e-licenser on XX-XX-2011”.

  • I’m trying to register C6, Mr. Steinberg Computer, not my e-licenser!!

Thanks for any help anyone who might be able to shed some light on this -

Bump to first page - thanks.

Have you tried entering it in the E-licenser control center?

I think products with licences downloaded to your E-licencer are automatically registered to your account.

Thanks, TwinOak and Richard Herbert!

You were right - I am registered. Confusingly (to me) the “Registered Products” list shows only one product registered - SX3. After poking around a bit more after reading your posts today, I saw that there was a drop down menu under SX3 - and it’s in that drop down menu that it displays that my Cubase 6 is registered…

I’m glad that seemed like a logical place to display Cubase 6 to someone!