Can't Register my License on MySteinberg

Hello everyone, i’ve bought the Cubase Elements 10.5 which don’t require that USB thing and i want to register the product on MySteinberg account to avoid losing it but everytime i try to register i get a message saying “Activation Code not found. Make sure that the code has been entered in the eLicenser Control Center.”

When i try to register the software in the eLicenser it says i can’t because i don’t have a usb dongle connected to my pc.

Is there a way to register the software without owning a eLicenser usb?

As far as i saw, the only thing that justifies having the usb is to own Cubase Artist or Pro so this is kinda confusing!

Hi and welcome,

You are right, you can activate Cubase Elements to Soft-eLicenser, you don’t need USB-eLicenser.

While activating the license in the eLCC application, make sure you enter an Activation Code, not a Download Access Code, please. If you don’t have an Activation Code so far, enter the Download Access Code in your MySteinberg account first to get the Activation Code, please.

Thanks for the reply!

Well, i dug up deeply into this matter and it turns out that for some reason my soft eLicenser and the program itself are broken beyond repair since i tried everything i can.

I contacted the Steinberg representant in my country but i still got no answers from them. It seems that i would have to format my whole PC to get this right due to the situation.

If someone knows any other way to fix this i would be very grateful!

When i try to enter the Activation Code into my Soft eLicenser i get a message saying that my Soft eLicenser is deactivated. And when i try to repair the Soft eLicenser, the process always fails because “At least one of the eLicensers used during this process was disabled and cannot be used for any license transactions.”

If i try to do the maintenance, i also get a problem in the Recovering License Transactions part. The message itsels says “A communication problem ocurred while acessing the license server. Please try again after downloading and installing the latest version of the eLicenser Control software, or contact your software vendor’s support departamente in case the problem persists.”



Try to start eLCC as administrator and trigger Maintenance. Does it help?

Unfortunately no :neutral_face:
I tried running maintenance, recover and repair soft eLicenser and i got errors in all of them. This is weird.


I’m afraid the only solution is to get in contact with official Steinberg support.