Can't resize Mixing window in Dorico 4.3

I just updated to Dorico 4.3 today and was dismayed to find out that when I open the mixing window I can no longer resize it!!! What gives? Please, please, tell me you are going to fix this. As you can see the bottom of the instrument names are chopped off. But the chopped off is besides the point. WHY take away the ability to resize the mixing window? I just don’t understand why something so simple has been taken away.

You took away the min/max/restore button so don’t ask me if I’ve tried clicking that. That’s just wrong. EVERY Windows window should have min/max/restore button!

image

I have no trouble at all resizing the mixer window in Dorico 4.3 on my computer.

Are you auto hiding your taskbar? The mixing window shows up for me fully ONLY if I auto hide the task bar. But I don’t want to hide the task bar. Also, the title bar for the window does NOT show up if I don’t auto hide the task bar.

Are you using Windows 10?

fyi, the title bar is the part of the window with the min/max/restore and close button.

Click on my name and you’ll see my setup.

Ok, you are using a Mac. We are talking apples and oranges. It’s not a fair comparison. The code for Dorico on the Mac is different than the code for Dorico on Windows.

Please find a Windows machine that has Dorico 4.3 installed and try it.

Looks like this is a bug that should get fixed like yesterday.

The Dorico team would be in the best position to comment on that. Dorico is developed within the Qt framework for both platforms, and to the best of my knowledge the Dorico team ensures that things work the same on both.

In short, the steps to replicate my problem are in Windows 10 and Dorico 4.3:

  1. Disable auto hide of the task bar
  2. Open the mixing window (not the panel)
  3. The instrument names at the bottom of the faders are chopped off AND the title bar doesn’t even show up (the bar at the top of the window with the min/max/restore/close buttons).

Well, I’m here to tell you it’s not working on Windows 10 when the task bar is set to not auto hide.

I’ve worked as a developer for over 20 years for banks and other types of companies and I can tell you no matter what, something about the software has to be different to be able to speak to two completely different machines (Mac vs. Windows PC).

Note to developers: I appreciate all the hard work that went into this update, but it appears that the last couple updates have left out vital features, most notably tool tips, which were absent for the most part from 4.0 to 4.3; I did notice some starting to show up in 4.3. Please stop rushing these features, albeit very cool, to production without finishing them. I would rather pay for incremental updates, than get them for free but not fully completed.

  1. Tool tips (and I did get one response that it’s something to do with the IDE for your dev work, but that’s not my problem. Tool tips are a basic feature of modern software. Ok, in all fairness some tool tips are starting to show up, so thank you.
  2. Please note the issue with the mixing window I’ve outline above.
  3. It appears the grid at the bottom for note editor still doesn’t remember the horizontal and vertical size settings.

After some more experimenting, what I found that temporarily clears up the problem until you shut down Dorio and open a project again: Turn the auto-hide feature for the task bar on and off or off and on, depending what mode you had it in to begin with. Then show the mixing window and it comes up normally. But it will not come up for me normally without the extra setup of turning on/off auto hide for the task bar and then again turning off/on auto hide for the task bar.

After more testing, now if I even just click the mixing window button and then click it again, the issue with the task bar/title bar shows up again, and then I have to go through and show/hide the task bar again. This is maddening.

I’ve just checked this myself on Windows, and I have no problem resizing the Mixer window. I think it might be a good idea for you to take the following steps, to see if this resolves the problem you’re experiencing:

  1. Quit Dorico completely.
  2. Type Windows-R to bring up the Run prompt, enter regedit and hit Return.
  3. When the user access control prompt appears, confirm that you do want to allow Registry Editor to make changes.
  4. In Registry Editor, navigate to HKEY_CURRENT_USER\Software\Steinberg-Dorico4
  5. Delete the dialogGeometry key, and all of is subways.
  6. Close Registry Editor.
  7. Restart Dorico.

Hopefully what you should now find is that all of Dorico’s windows and dialogs appear at the default size and position, including the Mixer.

Let me know how you get on.

Unfortunately, that did not fix the problem. I still don’t see the title bar; however, I do see things look better at the bottom of the window, that being, the instrument names are not cut off now.

Daniel, what version of Windows are you using? It’s not working for me and I have all the latest updates.

I’m using Windows 11, possibly not the very latest update because I rarely turn my PC on (it’s mostly for gaming, and I don’t get a lot of time for that, unfortunately).

However, no other Windows users – and they make up a sizeable minority of Dorico users – have reported this problem so far, so I think the issue is still going to be soluble on your system.

How many displays do you have connected to your PC? If there’s more than one, are they both the same resolution and pixel density, or do they differ?

The update just came out. I’m sure not everybody has updated to the newest version. does anyone on your team have Windows 10 and can confirm that it’s working on their machine?