Can't set focus to Marker track

A while back I set up three separate marker track ‘sets’ so I can easily reference which edits and lengths are required when I’m composing library music.

Today I’m trying to select the marker track I wish to use, but when I try to ‘set focus’ of the marker track I require, nothing happens, and it’s stuck on the first maker track.

Has something changed int he way it works?

Hi,

How exactly do “set focus”, please?

Hi Martin,

It’s accessed in the markers window.

I have a set of three marker track presets, normally I can switch between them, but now when I switch the others are greyed out and can’t be changed.

Hi,

To me it seems the other Marker tracks are locked.

The actual tracks don’t exist though, how do I unlock them?

Hi,

If the Marker tracks don’t exist, you can’t unlock them… Right-click to the Marker track and select Track Control Settings. Here move the Lock item to the Visible area (on the right side). Then you can will get the Lock button on the track.

Aah, I see.

I already have that in the track controls, no, the track isn’t locked.

Even when deleting the marker track and starting again, the two greyed out marker tracks still exist, but I can access them even when creating a new marker track.

I’ve had to create a new project and create 3 separate marker tracks, rather than having one track I can switch marker sets on.

Something has definitely got buggy.

Hi,

I’m not sure, I do really understand, how did you get to this state.

But there is the known issue of the “last Marker track”. If you have one Marker track with some Marker data, you delete it and then you add a new Marker track, you get the Marker data of that Marker track. The technical background is, there is always a Marker track in the project (same as Tempo Track or Signature track), the track is just hidden. So if you delete it, it just becomes hidden and once you add it again, it just becomes visible (of course, it should be deleted in this case, but this is the bug, it is not).

This bug is present for the very last Marker track only.

I’m just thinking, if your scenario is somehow linked to this one.

I think you might be on to something there.

Maybe it’s treating the second and third marker sets as ‘dead’.

I’ve run a small test, and imported the tracks into a new project, and all three marker sets are automatically given their own track, but they still aren’t editable in the window.

So it seems like the two issues could be linked.

Hi,

I have heard about this issue (Imported Marker tracks are not editable). But I have never been able to reproduce it on my side here.

Where does the project (you import from) comes from? What Cubase version, please? Could you share the source project (just with the Marker tracks), please?

Hi Martin,

The projects all use my master template, which I set the marker tracks up in a year or so ago, in version 10 of Cubase.

I’ve attached an empty project from the template which still has the original marker track, if you open up the marker window, you’ll see the other two inaccessible marker sets.

Thanks,

Jon
Markers.cpr.zip (61.6 KB)

Hi,

Thank you for the project.

I can reproduce the issue, the list in the Marker track remains dark. So it seems the Marker track is not in focus. But if you have a look to the Activate the track button in the Project window, you can see, the Marker tracks are Activated based on the settings in the Marker window (at least here on my side).

Hi Martin,

Glad you’ve been able to reproduce it.

Importing the 3 separate tracks does seem to work well. The trouble is they only work when imported. If I try to create a marker track manually, then assign a marker set, I’m not able to.

Thanks for your help.