Can't shorten multiple hairpins

In the scenario below, I’m used to selecting the mp and shortening the hairpin using Shift-Alt-right arrow.

I note that, when multiple hairpins are selected, I can’t perform that function. Is that an intentional limitation? Just curious. I tend to avoid linking, and I acknowledge this is one place where it would be helpful.

I just tried this and it works on my system.

Select two or more of the mp marks and you can shorten the hairpin?

Yes, I created 4 hairpins with an ending mp. Then, I unlinked them. Then selected all the mps and could shorten them via <Shift><Alt><right arrow>.

Is it possible there was something else selected? This often messes these things up.

Yes, but were your mp’s grouped with their respective hairpins?

I tried it that way as well. Initially they weren’t, so I grouped them. Interestingly, the shorten operation ungrouped them.

Can you post a cut down project for me to try?

bad hairpins.dorico (452.8 KB)

Select all the mp’s and try to shorten.

Yes, it works. Again, the dynamics become ungrouped after the operation.

Hello Dan,
I tried for you to select the four mp and shift + alt and left:the results:


Huh. I get neither of those results.

You can’t see the keystroke here, but after selecting all the mp’s, I’m pressing Shift-Alt-left arrow. Nothing happens. They stay grouped but don’t move.

One works fine:

DOH! What a dummy I am. I am using <ctrl><alt><right-arrow>.

But that doesn’t explain the single vs. multiple selection difference you are seeing.

My second test : I select the four mp in write mode do crtl-alt and left arrow also in write mode: and it works

I’m on a Mac and selecting all mp and then pressing SHIFT ALT LEFT-ARROW does nothing.

No, Shift-alt. To shorten the length of the hairpin.

On my pc: shift+alt + left arrow have no effects!
I wrote right: write mode : select the four mp than ctrl +alt + left arrow do the job

What language keyboard are you using? Not sure if that could be a reason.