Can't trigger pattern pad of GA SE4 w/ midi controller

I can’t seem to trigger the pattern pads of groove agent se4 using my midi controller. I have no problem triggering the instrument pads though. I am able to control other parameters like faders and knobs within GA SE4. I just can’t seem to get a handle on triggering the pattern pads. Can anyone shed some light on the matter please? I’m using Elements 8 trial. I’m also using Triton Le as the controller and m-audio usb uno as midi interface.

I’ve already tried creating two other MIDI tracks, assigning outputs to Groove Agent SE Main and Groove Agent SE Pattern respectively as advised in the manual. I still can’t trigger the pattern pads. Am I doing something wrong? Do I need to activate control for the pattern pads? If so, how? I also tried enabling and disabling “use midi port b for pattern pads” option but still to no avail. It’s not a deal breaker but I would really like to find out what’s wrong. I’m planning to purchase Elements 8 before the trial period expires since it’s the only available downloadable version available here in our country. I’ve been using Cubase LE 4 for quite some time now. I’m happy that I have the option to upgrade to a much better version. Thanks Cubase. I really appreciate the trial period. Great features on Elements 8. I hope higher end versions Pro and Artist will be available soon.