Can't upgrade license to C9

Is the server down, or just getting battered…?

I have the same problem .elicenser failing?

Getting battered I believe. same problem here

Same here unfortunately… :frowning:

keep trying, got through eventually…

Ahhhh after 7 tries, my license has finally been upgraded. Hope it will be working for you guys soon too!

me too

Same here. Seems like it is overwhelmed by requests I guess…

It won’t get through the Online Synchronization update for me. :-/

The same problem here. Another attempt… Problem with servers Steinberg? :wink: Ok after few attempts it finally goes

When I enter my ELicenser in the Grace Peiod Checker- Says I’m not eligible for the ‘Grace Period’ Update. I bought my 8.5 Brand new in late August of this year. I’d hate to think 4 months is too long for the grace period. Anyone else having this problem?


I kept on getting database maintenance errors and C9 authorization errors in the elicence window but I fired up C9 and it worked.

My errors were caused by not updating elicencer app, (maintenance does not do this)


same here…fails the initial Maintenance phase…:frowning:

Same here. Must have tried 20 times. But, sooner or later, I will get through!

After installing Cubase 9 my elicenser is not found at all,I can’t even use 8.5 as that doesn’t see it either it keeps coming up with LLC 2 Error window saying the licenser has lost connection.Have tried all the solutions,reinstall elicenser and elicenser helper app etc…The licenser still works on my other computer and I have used the maintanence procedure and that worked OK so it isn’t the dongle that’s faulty so what’s going on!

OMG! I was trying to upgrade the licence and due to server being down my cubase 8.5 licence disappeared…what the hell is this?i ope i dont have to wait to have it reactivated as i cant run 8.5 right now!

ottomo: keep trying the upgrade and all other licences should reappear. Happened to me.

Same Here! Cant do anything because it zapped my license for 8.5 and says I have nothing to upgrade and continues to fail connecting to server for maintenance. Probably 40 or 50 tries over several hours now. Confident it will work eventually but disappointed that there is not more licensing server capacity and don’t quite understand why it zaps the license for prior version before it is able to license the new version. That’s just bizarre right?

Same here, 8.5 license is gone aswell as it failed recovering it.

Edit: reboot system + eLicenser maintenance added the upgraded license. All good and working.