[Case Closed] Is there a way to change default master output plugins?

This case is closed due to the release of Dorico 3. Its mixer has a much faster operation response, and Paul’s idea still works well.


The real subject is: Is there a way (by manipulating the playback template file) to make sure the automatically added plugin on master output is Maximizer, not the Compressor?

Everytime I reload the NotePerformer playback template, the plugin configuration of master output gets overrided with a Compressor.

I am afraid that Compressor is always being inserted on master output by default in Dorico (I dunno whether the reason is the Playback Template or Dorico itself), and I am pretty sure that every Cubase / Nuendo mixer (a person who uses Cubase / Nuendo to mix projects) won’t simply place the built-in Compressor plugin onto the master output without a valid reason. (I tried my best to control my words here, but I still want to suggest the one, who invented this default setting, to, please, consult Nuendo development team about this.)

P.S.: Dorico 2.2.20, NotePerformer 3.2.0.

I do not like pre-set effects in dorico or anywhere else you can not disable.

There is no way to change this default setting at present: Dorico will always insert both a reverb and a compressor on the master output.

Thanks for your reply. Looks like the last resort is to manually remove the Steinberg plugin vst3 file bundle from Dorico by end users.

The inclusion of the compressor is intentional. We needed to have some kind of compression or limiting, since you will get clipping if the level exceeds 0dBFS. We tried out a few combinations but found a compressor to be a little more useful than just a limiter. The default setting is quite subtle with just a 2:1 ratio. You can change the setting in the compressor and then in the plugin window’s menu choose Default Preset > Save as Default Preset and it will use that by default in future projects. If you set it to 1:1 then this will effectively bypass the compressor. We wouldn’t use a maximiser by default because whether you use a maximiser will depend on the type of music and whether you are mastering as a separate step. It will create a louder mix, but will reduce the dynamic range.

In a future version we are likely to offer more control over the plugins that appear in the output bus. It really is not recommended to delete the vst3 plugin bundle.

To be honest, the compressor plugin does more negative effects to the dynamics. I wrote a chamber orchestra (for strings, piano, some mallet percussions, and woodwinds), and I found an issue that I have to use dynamic markings stronger than “f” to make the mallet instruments audible. This issue ends up with my manual removal of compressor plugin.

Maximizer does what you said above, but it won’t mess up the relative volume / loudness between each instrument part.

==This post is meant to be read by those people who wants to delete the plugin==

For those people who have strong hatred to the compressor plugin which is always inserted by default everytime you apply a playback template, you can simply remove the entire VST Audio Engine Plugin-set (unless you want to use other plugins shipped by Dorico).

on macOS:
“C:\Applications\Dorico 2\Contents\Applications\VSTAudioEngine2\COntents\VST3\VST Audio Engine Plugin-Set.vst3”

on Windows:
“C:\Program Files\Steinberg\Dorico2\VSTAudioEngine\Vst3\VST Audio Engine Plug-in Set.vst3”

If you want non-destructive approaches, you can use the file permissions settings of the file system you are using to make sure NO ONE can access the vst3 file (on Windows) / bundle folder (on macOS). Regarding how to do this on Windows NT (from Win2k to Windows 10) or on macOS, please consult StackExchange. Especially:

  • if you do this on macOS, make sure you have enough literacy about how to use bash / zsh shell. (macOS uses zsh since 10.15 Catalina.) If Dorico 2 doesn’t work after you touched the permission settings, you can either restore it back by using sudo privileges or reinstall Dorico 2.
  • if you are doing this on Windows, you have to bear in mind that you MUST memorize all steps of how to restore the permission settings. A Windows Server manager (certificated by Microsoft) can deal with possible failures or troubles happen during this process. I believe that typical consumers of Windows non-Server releases are having lack of literacy in Windows system management (which gets really sophisticated since Windows 2000).

If you don’t care the data occupation of your project file by the compressor plugin, you also have an alternative way to make the Compressor plugin not-functional by default by following Paul Walmsley’s suggestion above.

thank you very much @ShikiSuen and …

@PaulWalmsley thank you for your preset tipps and yes, please let totaly remove it or offer more control on next (Pro) versions. thanx

PS: As reverb plugin (not the default REVerence) i wan’t use precedence and breeze from 2caudio only, because there you can totaly control any room effects on every instrument, including humanizing features like virtual player moving https://www.2caudio.com/products/precedence#_Overview
( As a concept of my compositions, I do not always want completely static players. For example, I let soloists change location on stage as part of my performance practice )

I’m just curious why increasing the volume of that instrument (mallet) in the mixer a little more instead of changing the dynamics wouldn’t work.

The default compressor setting look pretty innocuous, but it seems to take the attack away from sounds more than the numbers on the dials suggest it ought to.

I haven’t done any controlled experiments comparing the audio though. Deleting it was less work than understanding it :slight_smile:

Every operation of Dorico Mixer lags a second or two on my Late-2013 Mac Pro (Though this issue disappeared on my laptop. Dunno why.).
Thanks to the nature of Qt 5, and I am pretty sure Dorico development team already did their best optimizing Dorico 2.
Now I am looking forward to see how Dorico 3 behaves.
(Now running macOS 10.14.6 with the Late-August Supplemental Fix.)

Don’t you know that this default compressor is the prime cause that makes NotePerformer 3 sounds horrible?
It is not the plugin’s fault, but the misuse.
This plugin is designed to process a single track (or a simple instrument) BUT IS NOT DESIGNED FOR SUMMED BUSES OR MASTER OUTPUT.

I simply want to quickly compose some orchestration and use sounds of NotePerformer 3 to do a quick output of track stems.
NotePerformer 3 itself has a fairly acceptable reverb, though it may not be comparable to professional reverb plugins in some cases.

I’ve never heard anyone describe Note Performer’s output as “horrible.” Hardly fair to compare it to a fine-tuned DAW mock-up with pricey VSTs, but it doesn’t sound overly compressed to me, at all.

I never described Note Performer’s output like that. I described what ravaged by the default compressor on Dorico master output.
NotePerformer 3 itself sounds good to me as long as the compressor gets turned off.
Not only me think of this way: https://twitter.com/ShikiSuen/status/1168520597715836930

P.S.: What you are defending for is making the situation worse, period.

Whether or not it sounds “horrible” to you, I don’t take instructions from some unknown person on the internet about what I am
supposed to think it sounds like, with or without the compressor.

Has anyone posted examples with and without the compression so that we can hear it for ourselves?

ETA: Scrub that - just tried it out on the beginning of Tchaikovsky / Romeo and Juliet and yes, it sounds better. I’ve attached a couple of Dorico files if anyone is interested in comparing the difference. You obviously need Note Performer 3. That said, I’m not a fan of the confrontational way this issue has been addressed. Nicely, please.
Romeo and Juliet (compression changed).dorico.zip (908 KB)
Romeo and Juliet.dorico.zip (908 KB)

Shiki is right about the usefulness of a good compressor in the master fader insert, with a “transparent” setting (as transparent as can be, for classical music). That’s something sound engineers do master, but not every musician. I understand why the team decided to put it there, especially when you consider the sonic quality of HALion, when dynamic balance is carefully expected… It avoids a lot of clipping and helps build a kind of coherence between HALion sounds.
As NotePerformer does perform way better than HALion in that domain, it can be a good idea to bypass or turn the compressor off. Nevertheless, if you hear some clipping, put it back on, with a 1.5 ratio starting at -10dB (that’s the threshold, the fader on the right of the compressor editor window.
And folks, remember that Shiki is Japanese, he might sound a little bit more aggressive that he would :wink:
Hope it helps !

The “default” parameters I have for the compressor in 2.2.20 are completely different from David Tee’s parameters.

So given a sample of two completely different data points, I wouldn’t like to guess what parameters sound “horrible” to Shiki.

David Tee’s score has the compressor set up to be pretty aggressive, and I agree that doesn’t suit a big romantic orchestra very well. But disabling it completely lets the audio clip on some peaks, so that’s not really a fair comparison either.

Hi Rob,

I was just following Shiki’s advice (second screen in the link that was provided). I’m not that skilled in this area so anything that helps it sound better is useful.

Marc and Shiki - apologies if I came over a bit judgemental…