Catalina > UR22C - What are Steinberg referring to in the compatible list?

When I open “About” in "dspMixFx_URC there er 4 version numbers:

Boot V1.00
Main V1.00
Driver V2.0.2
dpsMixFx UR-C V1.0.1

Which of these version numbers does Steinberg refer to on their Steinberg - Catalina compatible page?

The device firmware of your UR22C

dpsMixFx UR-C V1.0.1 refers to the firmware of the device itself.

I’m using the UR22C with MacOS Catalina. I’m using it with a USB 3.1 Gen 1 Type C cable that I purchased separately. It’s plugged into one of my Thunderbolt ports on my iMac.

So far it is all working as expected. Very happy.

My versions are:

Boot V1.00
Main V1.01
Driver: 2.0.2
DSPMixFx UR-C: 1.0.1

In the Yamaha Steinberg USB Control Panel I have it set to SuperSpeed USB 3.1 Gen 1.

Just one thing I’d like to clear up…

In Cubase Pro 10.5 there are now two options in the device list.

UR22C and UR22C (High Precision)

I’ve selected High Precision. Should I keep it at this or is there any reason I should select the other driver?

To make sure I was doing everything right I downloaded the latest version of TOOLS for UR-C V1.0.1 · 378 MB (Today 1. December 2019)

TOOLS for UR-C V1.0.1 · 302 MB
Included components

Yamaha Steinberg USB Driver V2.0.1
UR-C Extension V1.0.1
dspMixFx UR-C V1.0.1
Basic FX Suite V1.1.0

I started by uninstalling this:
Uninstall Basic FX
Uninstall Steinberg UR-C
Uninstall Yamaha Steinberg USB

Restarted and all that stuff.

Then I installed TOOLS for UR-C V1.0.1 · 302 MB (The latest version on Steinberg Support Site)

I’ve done that - everything done the right way, disconnecting USB stuff etc. I followed the InstallationGuide_en.pdf in every step.

And now my “About” window in dpsMixFx UR-C looks like this:

Boot V1.00
Main V1.00
Driver V2.0.1
dpsMixFx UR-C V1.0.1

The Driver has gone one step back - was V2.0.2

It would be great if Steinberg named the things the same all the way through. on the download site it is called:

Yamaha Steinberg USB Driver V2.0.1
UR-C Extension V1.0.1
dspMixFx UR-C V1.0.1
Basic FX Suite V1.1.0

In the about window in dpsMixFx UR-C its called:

Boot V1.00
Main V1.00
Driver V2.0.1
dpsMixFx UR-C V1.0.1

Who can tell what is what? I can’t - and I don’t want to have to guess.

Now I have downloaded and installed the Yamaha Steinberg USB Driver 2.0.2 · 3.3 MB

And now my “About” window in dpsMixFx UR-C looks like this:

Boot V1.00
Main V1.00
Driver V2.0.2
dpsMixFx UR-C V1.0.1

And I still have the question “Am I ready for Catalina”?

I hope Steinberg are planning to make an app to take care of these things like these companies have done:

Native Instruments
East West

All the best,

I guess the question is, is your UR22C working as expected? Are you able to select it as your audio source and hear sound?

You should update the firmware to the latest 1.01. It’s available on the Steinberg Downloads page:

Thank you ilmoto. It works as expected under macOS 10.14.6. except direct monitoring and everything is up to date (1. Dec. 2019).

But still, it shouldn’t be so complicated to update your tools/software. Why not make it an easy process when it is possible?

Here is a Steinberg link if the UR22C Input Settings Window is not visible in the Inspector in Cubase.

Is that the problem you’re having? That you don’t see the UR-C in the inspector? This info is not in your posts above.

As stated on the manual page you linked to, both Inputs and Outputs must be routed to the device for those controls to appear in the inspector.

So how do you have the device routed?

Hi Steve. I’ve just fixed it according to the article I linked to in my last post, “UR-C/AXR4T: Input Settings Window not visible in the Inspector” at Steinberg Support.

It works if I start with an “Empty” project and add audio tracks to that project.

I’ve just opened a two years old project, sat the input and output right in the “Audio Connections…”, added a audio track and the Input Settings Window is visible in the Inspector.

If I am right, it seams to only work with new tracks,(and that is not the big problem).

Thanks for asking Steve.

How did you test if it works with old tracks, or old projects? You might have to toggle the tracks’ routing in the general (the top) tab of the inspector. Have you done so with the misbehaving tracks/projects?

Is the routing Audio different in the old project, compared to the new?

I could only get the UR22C visible in the Inspector when I added new tracks to the old project.
The UR22C is not visible in the projects old audio tracks.

The Audio routing is different in the old projects, so I changed that to UR22C in and out’s.

Before any of this started to work I had to disable the “Control Room” in “Audio Connections”.

This is about existing projects created before I got the UR22C.

I have discovered that if I choose a “Group” as “Output” for an audio track, the UR22C is no longer visible in the Inspector - It disappears.

If I then choose “Stereo Out” again as “Output” for the audio track, the UR22C is visible in the Inspector - It appears.

Not sure what that is about…

That is simply how it works, as described above and also in the documentation.

So, I can’t send the audio signal to a group while recording… I have to change the output to a group after I record. Is that really so? Ok.

I guess I am thinking “the old” mixer to tape recorder and back to the mixer thing, where you always hear the same signal before and after recording.

Well if I don’t like this Steinberg way of doing it, I can always turn the “Direct Monitoring” off and use the dpsMixFx UR-C in the background.

Yes, apparently it is so.

One output must be routed to Stereo Out, and that leaves another that can be routed to the Control Room. This is different than previous interfaces, and I haven’t used it enough to know if I like this or not- or how to work around it, or even if it’s necessary.

So, can you send Mix 2 to the group, and Mix 1 to the Group?

Edit- Sorry, I have the UR44C which has two mixes, the UR22C has 1 mix outputs, so I think you have understood correctly. Seems a but disappointing, compared to the way the previous URs worked, where it was not necessary to have the Stereo Out routed to anything.

I only have one stereo output on UR22C.

But no problem. I have found a way to work with this. I set Track 1 to Stereo Out and the rest of the Audio Tracks are sent to their respective groups. I can still record on all tracks, I just have to go to Track 1 if I want to make changes to UR22C in the Inspector. :slight_smile:

Thank you for your time Steve.

bingo. :slight_smile:

Steinberg just released TOOLS for UR-C V1.0.2.


I am ready for macOS Catalina.

And now my “About” window in dpsMixFx UR-C looks like this:

Boot V1.00
Main V1.00
Driver V2.0.2
dpsMixFx UR-C V1.0.2