[CBT-1599] Problem recording midi from standalone controller app (Velocity Keyboard & others)

Hello Cubasis team,

I have an observation to report which is possibly a bug in Cubasis 3 since it is not present in Cubasis 2.

Reporting Form:

1. Summary/Title
Recording midi from standalone controller app (Velocity Keyboard by Blue Mangoo) does not work in Cubasis 3

2. Description
Here is description of a test I made comparing the behavior of 3 midi controller apps including Velocity Keyboard, which I posted in the Audiobus forum:

"… I just made a test in Cubasis 3… using midi controller apps KB-1, ChordPolyPad and Velocity Keyboard in standalone mode. In Cubasis 3 I have one midi track armed with the built in piano.

For all apps I changed the midi output options and in Cubasis in the track’s midi routing I tested “All inputs” or the midi controller app’s own output, if there was one available. Then I triggered the midi controller while recording into Cubasis.

ChordPolyPad:
1 CPP out: “CPP Midi Out” / Cubasis 3 in: “All inputs” --> piano sound is triggered and midi recorded
2 CPP out: “CPP Midi Out” / Cubasis 3 in: “CPP” --> piano sound is triggered and midi recorded
3 CPP out: “Cubasis 3” / Cubasis 3 in: “All inputs” --> piano sound is triggered and midi recorded
4 CPP out: “Cubasis 3” / Cubasis 3 in: “CPP” --> piano sound NOT triggered and NO midi recorded

KB-1:
1KB-1 out: “Virtual output” / Cubasis 3 in: “All inputs” --> piano sound is triggered and midi recorded
2 KB-1 out: " Virtual output" / Cubasis 3 in: “KB-1#1” --> piano sound is triggered and midi recorded
3 KB-1 out: " Cubasis 3" / Cubasis 3 in: “All inputs” --> piano sound is triggered and NO midi recorded
4 KB-1 out: " Cubasis 3" / Cubasis 3 in: “KB-1#1” --> piano sound NOT triggered and NO midi recorded

Velocity Keyboard:
1 VKB out: “All” / Cubasis 3 in: “All inputs” --> piano sound NOT triggered and NO midi recorded
2 (Cubasis 3 in: no “VKB” input available)
3 VKB out: “Cubasis 3” / Cubasis 3 in: “All inputs” --> piano sound is triggered and NO midi recorded
4 (Cubasis 3 in: no “VKB” input available)

In summary, for CPP and KB-1, there are midi output/input settings that work for triggering instruments and recording midi into Cubasis 3 (e.g. using the “Virtual midi port” created by the apps - (test 1 and 2). Test 3 (“Cubasis 3” midi out --> “All inputs” midi in) only works for CPP. For KB-1 and VKB the sound is triggered but no midi is recorded."

Recording midi from the standalone VKB app works as expected in Cubasis 2.8.3. In this case, “Cubasis” is selected as the midi destination in VKB and “Virtual Midi” is selected as the midi input in Cubasis 2. In Cubasis 3 there is no option for “Virtual Midi”.

3. Expected Results
By selecting “Cubasis 3” as the midi destination in Velocity Keyboard, and “All inputs” in the midi routing section of the track in Cubasis, I expect the instrument/plugin loaded onto the track to respond to incoming midi and the midi to be recorded when I press record in Cubasis.

4. Actual Results
Midi is not recorded even though sound is triggered. In most cases a midi event is created, and there might even be some notes “recorded” but they do not reflect the notes or timing of the midi actually played/sent from Velocity Keyboard.

5. Environment
iPad Pro 12.9 2018, Cubasis 3.0.1, latest versions of all midi controller apps.

Thanks for your help!
Kim

Hello Cubasis team,

Congrats on the new update 3.0.2.

You commented on this topic a while back on the Audiobus forum - have you had the chance to look into this, and maybe exchange with Blue Mangoo? The behavior persists with the new C3 update.

Cheers, Kim

Just an update - I have contacted Blue Mangoo and they are planning on looking into the issue on their side. In any case, there is a difference in the behavior between Cubasis 2.8.3 and 3.0.2: 2.8.3 works - 3.0.2 doesn’t.
BR, Kim

Hi Kim,

The issue has been added to our bugbase, and will be evaluated by our team.
At this point I’m unable to give you an estimate when the issue is expected to be fixed.

Thanks
Lars

Thanks Lars for adding this to your bugbase!
Kind regards, Kim

Hi kimeiroma,

While the issue has been added to our bugbase, it might take some time until our team is able to evaluate it, due to complexity and efforts required.

Best,
Lars

Hi, just an update:
The VKB app was just updated to v1.3 and this issue was looked into by Blue Mangoo according to what I understood. The update however did not fix the issue of recording into Cubasis 3 from the standalone VKB app.
Has the Cubasis team looked into this issue yet?
Best, Kim

Hans from Blue Mangoo here. We have reproduced the bug one time but can not reproduce it again and do not have steps to reproduce. I am sending a promo code for velocity keyboard to Lars Slowak via email.

Hi kimeiroma,

Our engineers are unable to reproduce the problem, given these steps:

  • Enable Background Audio in Cubasis 3 (Setup/Audio)
  • Add a MIDI track, it’s automatically set to all MIDI input ports
  • Open Velocity Keyboard and set it to Output to All or Cubasis 3 -> works as expected

Please let us have your feedback.

Best,
Lars

Hi Lars and Hans,
Thanks for looking into this. However I can’t seem to get this to work. What I want is to record midi into Cubasis 3 from the standalone VKB app, eventually to multiple tracks at once by arming the midi tracks (which is why I’m using the standalone and not the auv3 VKB app). There is no problem in triggering a sound on a midi track (built in or auv3 instrument) from the VKB app but when I try to record, nothing is recorded. I have made some videos demonstrating this. I will send you a link to this via pm.
Cheers, kim

I can confirm this.

Steps to reproduce:

  1. Open Cubasis 3 and start a new project
  2. Create a new midi track with default piano patch
  3. Enable background audio in Cubasis
  4. Open Velocity keyboard standalone app
  5. Open MPE bass preset in VKB
  6. Select Cubasis 3 as MIDI destination in VKB
  7. Return to Cubasis 3 and arm the track for recording. Then start recording
  8. Return to VKB and start playing

Expected result:
Sound plays and midi notes record

Actual result:
Sound plays but no midi is recorded

Hi Hans,
Thanks for testing and confirming. It seems that the Cubasis 3.1.2 update doesn’t fix this problem.

For comparison, I repeated tests that I detailed in my first post using the KB-1 midi controller app and the same behavior is there as with previous Cubasis 3 versions:

1KB-1 out: “Virtual output” / Cubasis 3 in: “All inputs” --> piano sound is triggered and midi recorded
2 KB-1 out: " Virtual output" / Cubasis 3 in: “KB-1#1” --> piano sound is triggered and midi recorded
3 KB-1 out: " Cubasis 3" / Cubasis 3 in: “All inputs” --> piano sound is triggered and NO midi recorded
4 KB-1 out: " Cubasis 3" / Cubasis 3 in: “KB-1#1” --> piano sound NOT triggered and NO midi recorded

So the “virtual output” in KB-1 works. Could there be a similar “virtual output” setting in VKB (“All”?) which would appear as “VKB” in the Cubasis 3 Midi Input options?
Cheers, Kim

Hi Kim,

What you are suggesting makes sense. I will look into it.

  • Hans

Hi Lars and Kim,

I have recorded videos to demonstrate the problem.

Here is velocity keyboard having the error recording midi into cubasis 3:
https://youtu.be/P9xWySY_IuA

And here is KB-1 having the same error, then resolving it by using its own virtual midi port as the input source:
https://youtu.be/azzoN0crK2k

  • Hans

Hi kimeiroma, Hi sirhans,

Our engineering once more checked the reports and clips provided by kimeiroma, and plans to add a fix in the upcoming Cubasis update.
I’d suggest to have you added to the beta program by mid of September, in order to check if the fix will resolve the problem.

Best,
Lars

Thanks Lars :slight_smile:

Thanks for your support as well… :slight_smile:

Thanks to both of you Lars and Hans - it’s great to hear to that the issue has been noted and that a fix is planned :slight_smile: