[CBT-2003] Real-time rendering of an audio file works incorrectly

To reproduce make following steps:

  1. Create a new project
  2. Create an audio track
  3. Load any audio file (doesn’t matter if it’s 48 or 44.1 kHz)
  4. Enable real-time rendering
  5. Create a mixdown or freeze the track
    The resulting file is playing faster and has pops and clicks.

My device is Xiaomi Mi 9T Pro running Android 10.

Hi solru.

Thank you for your message.
Gave the issue a short repro on the Galaxy S6 Lite:

  • Create a new project
  • Import “120 FlumDrums 03” drum loop from Media/Audio/Drum Loops"
  • Enable “Real-time Mixdown and Freeze” under “Setup/Mixdown / Frezee”

Both, “Track Freeze” and “Mixdown” lead to similar sounding results, compared to the original track.
Please let me know the additional steps, to reproduce the issue.


I’ve tested this issue further and found that this problem appears only when engine buffering is set to 20, 40, 64 and 84 ms.
Also I forgot to mention that I’m using the latest 3.1.1 version.

Hi solru,

Thank you for the additional information.

The pop/click issue is now reproducible and has been shared with the team.
However I am unable to reproduce the issue that the frozen track plays back faster.