CC information doesn´t show up (in Cubase 7.5)

Hi,

I couldn´t find this searching the forum, but when automating some parameters the CC in question doesn´t show up in the automation lane.

Let´s say automating the Morph filter´s controls. In the automation lane it says what is automated (frequency f.i.) but not the CC. Now I don´t want to automate it, but assign that to the auto lfo. How/where can I find the right CC?

Hope you can help me out,

Charles

Have you looked in the Key Editors’ controller lanes for this data? It is probably there.

Check out the CC Automation Setup menu item, aka MIDI Controller Automation Setup.

Thanks for your reply Steve!

Yes I have, but the Morph filter is a plugin. FX (inserts) information doesn´t show in the Key Editor? Unless I´m missing something…

I tried something else as well. Using Mystic and trying to automate the damping (see pic. 1). It does record the automation in an automation lane in the Project window (with write enabled), but again: I can´t find the CC information anywhere, nor does this show up as a controller lane.
CC.jpg
Trying to automate the fine pitch (see pic 2). In the parameters list, it says Pitch Fine, but doesn´t mention a CC. Is this not externally automatable as a CC?

I´m trying to get the concept here: all parameters in a synth or plugin are controlled by a CC, right? So that must be listed somewhere? And thus controlable?

I don´t understand this - couldn´t find this in manuals neither… What am I not getting?

pic 2:
CC2.jpg

I think you are confusing the CC automation with track automation. The morph filter is not a MIDI plugin and as such won’t have a “CC” assigned to it’s parameters. What you have to do is assign the parameter you want to control to a QC and then use the generic remote setup to map a CC to that QC slot.

Thanks JMCecil!

So I assigned frequency in the Morph filter to QC 1. In the device setup I see Track and VST Quick Controls.

In Track QC the address for QC 1 is 3. In VST QC the address is 70.

I tried to set up Auto LFO and tried both controller type 3 and 70 but neither respond. Can you tell me what I do wrong?

What you are trying to do (if I am reading correctly) is somewhat more complicated than you might think (but not impossible :wink: )…
Are you trying to get the Auto LFO to control QC1? (in this case, it is easier to use VST Quick Controls rather than Track Quick Controls)
If so, for that to happen, the input of the VST Quick Controls Device (i.e. the Device Panel) has to “see” the output from the Auto LFO, in other words, the output from a MIDI track, which has the Auto LFO inserted on it, has to be routed as the input to the QC Device Panel. For that, you will need some external MIDI Loopback software (unless you are on Mac, in which case that would be the built-in IAC Bus).
That means you have to either create a 2nd MIDI track (with the Auto LFO inserted on it), routed to the MIDI Loopback (or add a MIDI Send to the the original MIDI track) and the VST QC Device Panel has to have the Loopback return as its input.
Reading all that back, yes it does seem a little more complicated than it may be worth, but it does in fact work :wink:… the Auto LFO will control the input to VST Quick Controls, on the MIDI channel from the track on which the Auto LFO is inserted, and you’d set the Auto LFO’s “Controller Type” to the CC# number that corresponds with the desired QC slot (in the VST Quick Controls Device Panel)

There is probably some much simpler way of doing all that :blush: :stuck_out_tongue:.

Hahaha! :laughing:

Thanks for the care you put in your explanation Vic!

There is actually something else you could try…
Instead of using the Auto LFO, why not simply use one of the “wave” options of the Line Tool, to write the LFO directly on the Automation curve of the desired parameter. See page 283 of the manual for how to draw the waves in sync to the grid.

Thanks Vic!