CC Messages - Kontakt - Buggy Orchestral Templates

Hi guys.

Please help, I’m seriously considering leaving Cubase because i just can’t resolve these problems and am unable to complete any projects. Alot of this refers to Cubase 7/7.5 and i have 8 now but suspect the same things will happen.

I continuously try to make Orchestral music using my Casio Privia and on ocassions a Tec Control breath controller but in every single one of my templates the CC messages (Expression/Volume etc) go haywire at any random point.


THE ISSUES

Where to begin!

No matter my Midi preferences everything always seems to go tits up. Wether I have ‘Reset on Stop’ on or off seems to make no difference. I have tried various preference tweaks i have found online but no matter what the same thing happens in every project i make causing me to never complete a project.

Instrument levels could be fine the day i make it, then i come back to it a week later and all the volume has changed (usually too quiet). Some instruments are unaffected some are. The volume of all my kontakt instruments further down the timeline seem to become really quiet and i have to hold the Mod Wheel (Expression) up to hear any volume. If i don’t hold the expression wheel i can’t hear the instrument. This in spite of the fact that i tried the settings to reset any previous cc messages.

Another incredibly annoying thing that happens (and im sure this must be a bug) is that Kontakt Instruments i put into folders seem to bug out randomly and stop playing back any sound at all (unless i reload that instance of kontakt). It only happens to instruments inside folders and i think it happens after i have Soloed or Muted that particular folder. When this happens nothing i have tried can get it to playback unless i reload the patch then everything is as normal (but after spending days building 600ish track templates hopefully you can see my frustration)

Last major issue i have is that Kontakt patches will change volume within Kontakt. Despite having the Kontakt options to default the volume to 0 i will go in and the volume has lowered itself.


QUESTION

Please see the video below where Guy talks about recording Volume/Expression at the beginning of every track.

https://www.youtube.com/watch?v=HOWglixolyQ

My Question is - what are the correct Midi preferences to have assuming I do what Guy does in that video? In order for that to work effectively should Reset On Stop be on/off? Should i be chasing events? Etc Etc Ideally I really need a checklist of preferences that should be on/off to safeguard against the issues i encounter above.


Please help i really don’t know what else to do. Its always the same thing. I can spend a week making an amazing template of 5/600 tracks, make 8 bars of music and then suddenly the CC messages go nuts.

Hello,

Have you used the Casio with any other DAWs and noticed similar issues by chance? It sounds like your controller may be sending out sporadic midi data which is often caused by pots in the controller wearing down. Are you recording any CC data on the midi tracks? If you record, or manually pencil in CC data for the major parameters of your instruments (expression, mod, main volume) then the automated midi data should overwrite any messages your Casio may be sending out. You might want to check the documentation for your instruments too as sometimes they use odd CC #s for advanced control of volume or filters. As for changing volume within Kontact, do you have any quick controls assigned? If you assigned a quick control to volume you could be bumping it by accident.

Sorry if this isn’t helpful but it sounds like a couple issues I had before and these were the solutions. Good luck!

Hi thanks for your reply. I don’t use other Daws and only use the Modwheel to record expression/dynamics. Not a fan of quick controls either. Do you know how i can test if the Privia is firing out unnecessary messages?

Scenario -

one day i make 8 bars of music and record all the expression for those 8 bars using the Privia’s modwheel. Everything is perfect and ive spent all day doing it so i retire for the day, close down Cubase etc

The next day i decide to start on the next 8 bars. I’ll give a few bars headroom and start doing things as usual.

Except i can’t because now all of a sudden

  • random tracks play really quietly unless i push up the mod wheel (like the volume is being forced low)
  • Kontakt has suddenly decided to lower the volume on a few patches.
  • Some instruments just don’t play at all
  • Instruments that were in folders don’t play unless reloaded ( ive figured this has something to do with soloing or muting the folder as a group)

I heard that playing with Reset On Stop can help but it doesn’t, if anything it causes other issues. There’s one or two other Preference tweaks recommended but none of them seem to stop the issue.


It all becomes such a chore it is near impossible to actually make any music.

Had a similar mod wheel sporadick cc output on my korg MS20 controler keyboard and had to physically diconnect it from the pcb to stop the problem. The only way you can check this is record on a track & move the wheel then return to off position. keep on recording & you should see cc messages coming in. This means that when you have already recorded your expression and may be playing in a few extra notes etc the mod wheel will be overiding your original expression.
Try a different keyboard and disconect your casio.
Mike001

Thanks Mike definitely going to try that.

Sorry it was early in the morning but i forgot to say im actually using a second keyboard (Korg Microkey) to control Expression because the Privia doesn’t have a mod wheel. So i play the Privia but control midi with the Korg.

Could be the korg then.
Mike001

Yah my money would be on one of your devices sending out spontaneous signals. I’d try what mike suggested with each midi device 1 at a time. I had the same thing happen with a bunch of CC pots on my old Maudio usb keyboard and ended up having to replace it which may be your case as well unfortunately.

But, don’t give up on Cubase. Its used by many pros in the field of cinematic, film, orchestral music, without such issues. Whatever the problem is, its not Cubase.

This may not be related, but a member of the Reaper forum came across a similarly infuriating problem with his Casio keyboard and some Kontakt instruments.

Casio have started implementing High Resolution Velocity on some of their recent models. If you haven’t come across this, it involves a CC88 message being sent with every Note On. In the instance I saw it was causing strange sustain problems with NI’s New York Concert Grand instrument, presumably because CC88 is used internally in the instrument’s scripting. Also affected were Kontakt’s Upright Piano, Berlin Concert Grand and Vienna Concert Grand, though the effect was much less noticeable in those.

I’ve got some other Kontakt instruments that explicitly warn not to use a range of CCs (including CC88) for automation because they’re used internally in the instrument’s scripting (Embertone’s Cello, Viola and Violin).

Reading around a bit suggests that until recently almost no keyboards implemented Hgh-Resolution Velocity. It also seems to be rare for a plugin to respond to it (deliberately, that is), Pianoteq being the notable exception. The need for 16 thousand-odd discreet velocity levels escapes me, but I’m wearing hearing aids so may not be the intended market for this feature.

As I said, this may have nothing to do with your problem, but you might want to monitor the midi coming in from your Privia to see if you’re getting unwanted CC88’s, and if so filter them out.

Thank you guys im going to test the two keyboards in the next couple of days once i’ve fresh installed Cubase. Gmgmgm thats really useful to know wether relevant or not. I will make sure to look out for cc88. Cheers. :smiley:

Weird thing is I had the same thing this morning.
CC1 mod wheel transmitting for no apparent reason.
Updated Kaspersky Internet protection & Windows which was just a Defender update.
Disconnected all my midi & usb in’s, set scan disk to check on next boot up & switched off.
Reboot with no midi inputs & no midi cc’s.
Switch off & plug in 1 of them & no midi cc’s.
Did this lots of times until all plugged in again & midi cc’s back possibly from my Korg MS20 usb controller keyboard.
Which is strange as I phyisically unplugged it from the pcb years ago.
Twiddled all the pots reboot & all seems ok for now.
Maybe some sort of driver issue but it doesn’t come with one.
Very odd that it should happen to the person giving you advice.
Also both of us have a Focusrite but mines a Scarlett 18i6.
Very odd behaviour.
Will keep you informed.
Mike001

Hmmm i was hoping that might be the solution but there are no other CC’s triggering with either the Korg or Casio. :unamused: :unamused: :unamused: :unamused: I thnk this is a preferences issue.

Try assigning a MIDI Monitor to the track and see whether the keyboard is ran smithing CC messages when nothing else is going on.

Push F2 to get up your play bar.
Create a midi track with nothing assigned to it and no midi keyboards or controllers plugged in or their outputs or throughs.
Hit record and see what you get.
You will see midi activity in the playbar or you will have recorded some midi cc’s in your unassigned track possibly.
This is great as a starting point.
Then switch of your Daw and reconnect your midi inputs/outputs one at a time.
Then reboot.
Maybe you are ghosting your midi on a through port?
Mike001