CC121 motorized fader issues Cubase 10.5.12

I don’t know if this is coincidence, but since i updated from cubase 9.5 to 10.5 the motorized fader is behaving strangely.
The fader stops following the track volumes of the selected track after about 15 seconds or so. Pretty erratic when it happens. Then if i give the motorized fader a nudge it catches up and starts moving again.
If i create a new song and track (midi or audio) and move the fader or automation volume line without playback, the motorized fader follows it as it should then does the same thing and freezes until i nudge it physically.
Kinda does sound like a hardware issue but it started exactly after i updated to cubase 10.5, and also does the same thing if i go back to 9.5 now.
I worked out that if you adjust the sensitivity of the CC121 down to 1-3, the fader stops picking up touch signals so cubase wont follow when i move it physically but then if i move the volume in cubase the motorized fader doesn’t get stuck this time.
Tried all the usual; re installed cubase/CC121 latest drivers/Yamaha USB driver. Actually opened it up to see if it was getting caught on anything, dust or dirt.
Maybe its coincidence and the fader is on its way out.
Hope that all made sense. Has anybody ever had this?