CC121 not recognized in Cubase 10

I don’t know if it’s cubase 10 or cc122 issue,
Cubase doesn’t see cc121, no matter what I tried, reinstalling drivers, different usb cables, etc, no luck,
“Cubase ready” light just flashes and doesn’t go solid.


Do you still have Cubase 9.5 installed on your system, please? Does CC121 works in Cubase 9.5 to you?

I also still have cubase 8, tried in 8, can’t get it to work there either


I had the same issue, probably caused by Windows update. Install the CC121 driver again. Make sure you install the driver and the extension is installed.

C10 now has full support for PreSonus Faderport. I am not sure if this was a 9.5 feature but I got FaderPort to work on my Mac OS 10.13. Everything works. You can even get to output channels. It has been a long time using HUI and not having all of the features. I did see where the CC121 is no longer on the setup menu. Really happy about the Faderport support.

I have a cc121. I updated to Cubase 10 with zero issues at all. For me it worked without doing anything.


Driver reinstallation worked on my side on Windows 10.

Found an old midi driver form Yamaha site, installed it, worked.
For some reason the driver for cc121 didn’t work.

Please, you kindly provide more details? Did you mean Faderport classic or V2?
I was waiting for Cubase on Mac support for Faderport for ages.
And have both C10 and Faderport, but it still HUI only - how you managed to setup it in devices (for me it is not there)? Could you provide some screenshots of settings?